Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #332673


    In my child theme -> general layout -> dimensions 1200px container width
    I’ve put the same dimensions for the layer slider on the homepage + responsive + maximum width 1200px. And background images are also 1200px width. So I really don’t understand why the slider is wider than the container width… ??

    Thanks for you help !
    Kind regards,



    the embeded Layerslider is always full-size



    Thank you for using Enfold.

    @marienoisette: The layer slider will always be set as fullwidth. Try using the Easy or Accordion slider instead. You can place them inside a 1/1 column layout.

    @melonmelon: Thank you for explaining.



    Thanks to both of you, really.
    But I really don’t understand, as actually it’s possible to set a maximum width in the layer slider settings…? And as you can see on my link my layer slider isn’t really fullwidth… apparently at least. I know it is fullwidth indeed if I put back the borders and shadow… but my goal was to give the appearance of a non fullwidth… which is nearly the case !! Wouldn’t you have a little trick to align the “appearing” layer slider with the container width ?? Would be great as I’m not to far from it !!
    Sorry I don’t want to bother nore to insist… but unfortunately I won’t have the same setting possibilities AT ALL with the easy slider (font, size, colors, movements, buttons etc… This is the reason why I chose the layer slider …
    Thank you very much again.



    Regarding this “non alignment” width between layer lifer and container… Please could you check the “nous connaître” page.
    I’m just trying at this stage to see how would look a submenu on top of this page just below the main menu, and also how it would look if I use a widget in the right column. Anyway, as you can see, with the top submenu (aligned on the right) there is also a problem -> it’s not aligned on the right with the main menu…
    I’m wondering if the 1200px size I chose for the container is really working… ?? see what I mean ? Hope my explanation are clear…
    Thank you for your patience.


    Ismael, me again… I don’t want to be a pain really and I’m sure you’ve got a lot of work which I understand.
    I just wanted to complete my message with this link :
    The slider of this first page is exactly what I need I guess, it’s not fullwidth…
    If really there is no solution with the Enfold Layer slider do you think I should buy the plugin ? I would have preferred to avoid that but if it’s the only solution I will do so. I also need to be sure that adding this plugin will not have bad incidence with the theme and the code.

    Keep me posted when you can of course. Thank you.



    You can achieve a “boxed” layerslider by trying the following steps

    1. Go to LayerSlider in the backend.
    2. Choose the slider you want to edit and click Slider Settings
    3. In the Layout tab, specify the slider width in px and turn off the fullwidth setting.

    4. Copy the slider shortcode.
    5. Go to the page where you wish to add the slider
    6. Add a 1/1 container to Advance Layout Editor and add a code block to it. Paste the shortcode to it.

    Best regards,


    Hey Arvish !

    Thank you very much for your help.
    I had done 1-2-3 already, but I had added the slider direct, not specifically in a 1/1 container and not through the shortcode.
    At first I thought your solution was working and I was so happy… :) but then I realized it was not working very well. It takes more time than expected to get really started + I’ve lost arrows on both sides…

    Unless you get a better idea, what about going back to where I was (first method), but reducing a little the slider width in the slider settings? The main container size I chose is 1200. But it includes small margins on the right and on the left, right? Let me know if I’m wrong.. So do you think it could work if I set the slider width to 1200-40-40 -> 1120px ? Bad idea ?

    Thank you very much again !
    Kind regards,


    Hey !
    Following my previous message, here is what I finally did which seems to work : I left my LS at 1200, and I changed the main container (in Enfold/General layout/dimensions) to 1300 (instead of 1200). Everything is “aligned now” and it looks perfect to me :) / well, it’s not aligned anymore when I really stretch down the screen window but it’s ok for me. That being said, I’m not a developer… I don’t want to “set” things that wouldn’t be “clean” regarding the code and the theme… Please can you just confirm there is no “problem” with doing this ?
    Thank you Arvish, Ismael, everyone !


    HI Marie,

    I don’t see a problem with that as you are using the theme available options.


Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Layerslider size’ is closed to new replies.