Tagged: 

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1110221

    Hi there,

    My past developer helped me build this site 3 years back..

    After the server updated to Php 7 and WP and Enfold is updated to the latest version, the “header” image do not work on the inner pages anymore.

    It will cause the inner pages to load a white screen after the Top part with logo and menu bar is loaded.

    No issues on the homepage as the homepage did not use any sliders.

    Here is the code of the child theme header.php that load the layerslider:

    
    text/x-generic header.php.old ( PHP script text )
    <?php
    	global $avia_config;
    
    	$style 		= $avia_config['box_class'];
    	$responsive	= avia_get_option('responsive_layout','responsive');
    	$blank 		= isset($avia_config['template']) ? $avia_config['template'] : "";	
    ?>
    
    <!DOCTYPE html>
    <html <?php language_attributes(); ?> class="<?php echo " html_{$style} ".$responsive." ".avia_header_class_string();?> ">
    <head>
    <meta charset="<?php bloginfo( 'charset' ); ?>" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    
    <!-- page title, displayed in your browser bar -->
    <title><?php if(function_exists('avia_set_title_tag')) { echo avia_set_title_tag(); } ?></title>
    
    <?php
    /*
     * outputs a rel=follow or nofollow tag to circumvent google duplicate content for archives
     * located in framework/php/function-set-avia-frontend.php
     */
     if (function_exists('avia_set_follow')) { echo avia_set_follow(); }
    
     /*
     * outputs a favicon if defined
     */
     if (function_exists('avia_favicon'))    { echo avia_favicon(avia_get_option('favicon')); }
    ?>
    <link rel="shortcut icon" href="<?php bloginfo('url');?>/favicon.ico"/>
    <link rel="shortcut icon" href="<?php bloginfo('url');?>/favicon.ico?" type="image/x-icon"/>
    
    <!-- add feeds, pingback and stuff-->
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="alternate" type="application/rss+xml" title="<?php echo get_bloginfo('name'); ?> RSS2 Feed" href="<?php avia_option('feedburner',get_bloginfo('rss2_url')); ?>" />
    <link rel="pingback" href="<?php bloginfo( 'pingback_url' ); ?>" />
    
    <link href='http://fonts.googleapis.com/css?family=Lato:300,400,700,900' rel='stylesheet' type='text/css'>
    <link href='http://fonts.googleapis.com/css?family=Arimo:400,700' rel='stylesheet' type='text/css'>
    <link href='http://fonts.googleapis.com/css?family=Open+Sans:400,700' rel='stylesheet' type='text/css'>
    
    <!-- mobile setting -->
    <?php
    
    if( strpos($responsive, 'responsive') !== false ) echo '<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">';
    ?>
    
    <!-- Scripts/CSS and wp_head hook -->
    <?php
    /* Always have wp_head() just before the closing </head>
     * tag of your theme, or you will break many plugins, which
     * generally use this hook to add elements to <head> such
     * as styles, scripts, and meta tags.
     */
    
    wp_head();
    
    ?>
    
    </head>
    
    <body id="top" <?php body_class($style." ".$avia_config['font_stack']." ".$blank); avia_markup_helper(array('context' => 'body')); ?>>
    
    	<div id='wrap_all'>
    
    	<?php 
    	if(!$blank) //blank templates dont display header nor footer
    	{ 
    		 //fetch the template file that holds the main menu, located in includes/helper-menu-main.php
             get_template_part( 'includes/helper', 'main-menu' );
    
    	} ?>
    	
    	<div id='main' data-scroll-offset='<?php echo avia_header_setting('header_scroll_offset'); ?>'>
    
    	<?php do_action('ava_after_main_container'); ?>
    	<?php
    	if(!is_front_page()){
    	?>
    	<div id="inside_page_slider">
    		<?php echo do_shortcode('[layerslider id="22"]');?>
    	</div>
    	<?php
    	}
    	?>

    I believe it just needs some changes to make it work.

    As I cannot find the past developer anymore, I hope you will be able to help me out please.

    Thanks!

    • This topic was modified 1 month ago by  net-guru.
    #1110241
    This reply has been marked as private.
    #1110831

    Hi net-guru ,

    Can you please make that account admin? We cannot really see anything like this, not even the Layer Slider.

    Best regards,
    Victoria

    #1111019
    This reply has been marked as private.
    #1111354

    Hi net-guru,

    Thank you.
    Please change the line with do_shortocde…with

    
    <?php layerslider(22) ?>
    

    Best regards,
    Victoria

    #1114166
    This reply has been marked as private.
    #1114332

    Hi net-guru,

    Is the header file form the updated version or from the old one?

    Best regards,
    Victoria

    #1114443
    This reply has been marked as private.
    #1114666

    Hi net-guru,

    Please try the code from the new header.php and make your changes on top of it.

    Best regards,
    Victoria

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.