Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #1092700

    Hi,

    I’m trying to get layer slider to work on mobile and it appears to be squished (see attached screen shot). Is there a setting I have wrong?

    The url of the site this is on is: veggiegardenfilms.com/test

    Jim

    #1092867

    Hey Jim,

    I can’t see a screenshot but please post admin login details in private so that we can have a closer look at your slider.

    Best regards,
    Rikard

    #1092921

    Thanks!

    Sorry, here’s the screen shot. I’ve included the login details in the private content.

    Jim

    • This reply was modified 3 months, 4 weeks ago by  jimmiesner.
    #1093245

    Hi Jim,

    Thanks for that. You have this coming from your child theme:

    @media only screen and (max-width: 480px) {
    .ls-wrapper.ls-in-out, .ls-wrapper.ls-in-out div {
        height: 60px!important;
        width: 100%!important;
        left: 0%!important;
    }
    }

    Could you try to remove that to see if it helps?

    Best regards,
    Rikard

    #1093365

    Thanks Richard,

    I removed that code. Is there also a way to make the video full width on mobile?

    Jim

    #1093523

    Hi,

    Thanks for the update.

    Did you set the video layer as the slider background? Just look for the “Use this video as slide background” option in the layer’s Content panel.

    Best regards,
    Ismael

    #1093659

    Thanks. That’s great. It fills the slide, but I can’t get it to play or go to the next slide now. Is there an issue with my video provider?

    Jim

    #1093998

    Hi,

    Yes, maybe it’s not working because of the video source. We haven’t seen anyone use that media provider before. Try to use youtube or vimeo instead of mediazilla.

    Best regards,
    Ismael

    #1094009

    Ismael,

    Thanks. I tried a vimeo video but I’m not getting any sound. It’s important that there’s sound as this is a portfolio. Is there always no sound when background video is selected? If so, is there another way to do the video full width that allows sound?

    Jim

    #1094266

    Hi,

    Thanks for the update.

    The browsers won’t allow autoplay for media files with sounds, so they have to be muted if you want them to automatically start on page load.

    // https://developers.google.com/web/updates/2017/09/autoplay-policy-changes

    One workaround is to open the video inside a lightbox. Just create a standard slider with a static image background and then create a button that will open the media file inside a lightbox container.

    Youtube actually discourages the use of videos as background when they remove the parameters that allow users to disable the info inside the frame.

    // https://developers.google.com/youtube/player_parameters#release_notes_08_23_2018

    Best regards,
    Ismael

    #1094292

    Ismael,

    Thanks. Would I need to upgrade layerslider to do this? I am having trouble finding documentation to help me accomplish that.

    Jim

    #1094596

    Hi,

    Thanks for the update.

    No, you don’t need to upgrade the layer slider. Just create a slider with a static background and a new button and put the video url as the target or link. Make sure that it’s from youtube or vimeo. Clicking on the button should open the media file inside a lightbox container. Unfortunately, we can’t do anything with the muted video.

    Best regards,
    Ismael

    #1094860

    Ismael,

    Thanks! That plays now. I have a couple of more questions if you don’t mind.

    1) I tried making the slider smaller, but couldn’t figure out how. When I tried putting it inside a content element that was 3/5 the size of the page it wouldn’t allow me to. Is there a way to make it smaller on desktop. The size is perfect on mobile.

    2) When the video comes up on mobile, it comes up a little below the static thumbnail. Is there a way to layer it so it comes up right over the static thumbnail? See attached image.

    #1095243

    Hi,

    Thanks for the update.

    We’re trying to edit the slider, but the changes aren’t taking effect. Is there a server cache? We actually removed the layer slider in the “test” page, but it’s still displaying in the frontend.

    The current slider layout is not that complex, so you’re probably better off using the Full Screen Slider instead of the Layer Slider. That slider will automatically inherit the size of the browser window.

    Best regards,
    Ismael

    #1095426

    Ismael,

    Thanks. I changed to Full Screen Slider but I can’t get the video to fit inside a container with that either, nor can I get it to play. Do I have something set wrong?

    Jim

    #1096058

    Hi,

    Thanks for the update.

    The video has to be muted in order for it to automatically play on page load. We enabled the “Mute Video Player” option in the slider settings.

    Best regards,
    Ismael

    #1096248

    Ismael,

    I don’t understand your response. I was not trying to get the video to play automatically. I was just trying to get it to play.

    I was able to figure out a solution by using the easy slider though. Thanks for your help and have a great day.

    Jim

    #1096630

    Hi,

    I’m glad this was resolved. If you need additional help, please let us know here in the forums.

    Best regards,
    Jordan Shannon

Viewing 18 posts - 1 through 18 (of 18 total)

The topic ‘Layer Slider Small on Mobile’ is closed to new replies.