Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #250809

    When I look at my site on my desktop, the Layer Slider works as it should. The transitions are smooth and predictable. When I open the LS on the iPad, the transition blacks out and then flashes the slide before going back to a black out. Could you please help!


    Please reply and I’ll PM you access. Thanks!


    Hey loganwilliamson!

    Please post login details here privately so we can take a look


    This reply has been marked as private.


    In Slider settings i have set Responsive under to 1140. Can you check it now



    This didn’t help. If you have access to an ipad, it might be helpful to see what I’m seeing. Any other thoughts? Thanks for working on this!



    Unfortunately i do not have a chance to check your website on an actual iPad. Please try flushing browser cache on your mobile device and refresh your page a few times. If issue remains, please post a screenshot

    Best regards,


    Cleared browser cache and problem remains. It is hard to recreate through screenshots because it is the transitions that are off. In fact, I was going to recreate it through describing it through text, but it is so wonky that I can’t even begin.

    The transitions look as they should on Galaxy Smartphone. :/

    Is there any other solution for you to see it?



    Thank you for the info.

    I check the site on an iPad and it loads a little slow. Maybe, it has something to do with your host. Another thing is, the images are not optimized. Example is this image http://jamesonpowers.com/wp-content/uploads/2014/04/DM2.png which is 1000x667px in dimension but is currently 1.6mb which is huge. I think you should try and optimize the page speed and upload images with smaller file size. You can do the following courtesy of the wordpress community:

    1. Optimize all images with AI/Photoshop before uploading to server ‘save as web safe’ jpg
    2. Once all images are on the website optimize with ewww optimizer plugin twice 1hr 10mins apart.
    3. Install wp-smushit run once to remove jpeg extra data, then uninstall.
    4. Use BWP minify plugin to minify scripts and stylesheets.
    5. Install WP-Super cache, select all recommended settings.
    6. Logout your website, visit every page at least once to create super cache files.
    7. Join Cloudflare setup your website on their CDN, Choose options: Full CDN Optimisation save then activate purge files. once done log out.
    8. Have a cup of coffee.
    9. Visit your site after 20 minutes or so.
    10. Don’t forget to smile.




    I’ll try all of that and get back to you. Thanks for the detail. :)




    I hope it works. In addition, convert to the background images, or every other images to jpg format as suggested on the first step for optimization. They can be minimized to less than 100kb in size. Regarding the layer slider, dish out the 3D transition then use 2D effects instead. Let us know if it improves the loading speed.




    Ok, I followed all of your suggestions and the speed is great. I do need the transitions to go slower, but overall much much better.

    I’m having a similar problem that I have had with other sliders. The layers that I have that look great on my desktop are misplaced on my ipad. ie. the words are moved to off the screen. Any suggestions? Thanks so much for giving me the other suggestion about changing the effects. :)






    Glad it is faster now.

    Actually, the first slide’s caption is misplaced even on desktop view. On the layer slide settings > Full-width slider settings, did you specify the width for Layers container field? Put 1140 for Responsive Under, and 1140 again for Layers Container option. I hope that helps.


Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.