Viewing 30 posts - 1 through 30 (of 48 total)
  • Author
    Posts
  • #329108

    Just did the update, and my front page slideshow isn’t showing up. Inspect Element in Chrome says “Uncaught SyntaxError: Unexpected token ILLEGAL”.

    #329131

    Hi!

    Can you check if this happens with all LS sliders? try creating a new LS test slider and put it on a new page and check if the issue persists there too.

    Cheers!
    Josue

    #329133

    Yes, I’ve been testing this all morning. IE’s debugger was the most helpful (I know, right?), and pointed out the problem. Here’s the Error:

    Console: SCRIPT1023: Expected hexadecimal digit

    Debugger: lsjQuery(“#layerslider_10”).layerSlider({responsiveUnder: 1920, layersContainer: 1920, hideOnMobile: true, hideUnder: 400, twoWaySlideshow: true, loops: 10, skin: ‘fullwidth’, navStartStop: false, navButtons: false, hoverBottomNav: true, showCircleTimer: false, thumbnailNavigation: ‘disabled’, skinsPath: ‘http://beta.geology.utah.gov/wp-contentE:\www\ugsweb\wp-content\themes\enfold\config-layerslider\LayerSlider/static/skins/’})

    I bolded the problem (I don’t know how to fix it though since the problem is a folder path is the root folder for my entire site). I guess /u is unicode and expects a hexidecimal digit afterwards (http://msdn.microsoft.com/en-us/library/ie/13ht9e2w(v=vs.94).aspx). If the /u is to be interpreted literally, there needs to be a //u. Any ideas how to fix this?

    #329148

    Hey!

    Try changing the $skinpath directly in /config-layerslider/LayerSlider/init.php, line 41:

    $skinpath = $GLOBALS['lsPluginPath'].'skins/';
    

    Best regards,
    Josue

    #329155

    That may be my problem…I don’t have a init.php in that folder path…I have an index.php and layerslider.php and a bunch of other folders.

    #329179

    Is this a file that I should have?

    #329206

    Hi!

    Yes, it should be there – http://i.imgur.com/m2lHa4S.png

    I’d suggest re-uploading the theme again via FTP.

    Best regards,
    Josue

    #329233

    I just downloaded the newest version of enfold directly from themeforest.net and there is no init.php file. What am I missing here? http://i.imgur.com/5ZyoqU4.png

    #329293

    Hi!

    My mistake, i was looking at a slightly older version of Enfold.

    Regarding your issue, i tried checking it again but it no longer has a LS slider on the homepage.

    Cheers,
    Josue

    #329298

    I replaced it….the broken one is back.

    #329352

    Just to discard, have you tried disabling all third-party plugins to see if it gets fixed?

    The root of the issue is indeed the \u thing in the skinsPath declaration but it is weird that your site builds the URL like that:

    beta.geology.utah.gov/wp-contentE:\www\ugsweb\wp-content\themes\enfold\config-layerslider\LayerSlider/static/skins/

    It should be just:

    beta.geology.utah.gov/wp-content/themes/enfold/config-layerslider/LayerSlider/static/skins/

    Regards,
    Josue

    • This reply was modified 5 years, 2 months ago by  Josue.
    #329373

    Disabling plugins didn’t help either unfortunately. I would love to continue using the layer slider. Do you know where in the code the skinspath declaration is being constructed (I haven’t been able to find it)? There wasn’t a problem with the most recent version of Enfold.

    #329400

    Hi!

    It’s in /enfold/config-layerslider/LayerSlider/includes/slider_markup_init.php, line 36:

    $slides['properties']['attrs']['skinsPath'] = dirname(LS_Sources::urlForSkin($skin)) . '/';
    

    Try changing that to:

    $slides['properties']['attrs']['skinsPath'] = 'http://beta.geology.utah.gov/wp-content/themes/enfold/config-layerslider/LayerSlider/static/skins/';
    

    Regards,
    Josue

    #329573

    I was having the same issue and that solution worked for me. Thanks

    #329726

    Hey!

    Glad Josue could help :)

    Cheers!
    Yigit

    #329775

    I went through a bad time, but luckily that solution worked for me to.
    Thanks

    #329864

    Glad it worked for you guys, hope it does for OP too :)

    Cheers!
    Josue

    #329865

    Thank you for your help. That fixed the issue. I really appreciate all the hard work you guys put into this product.
    Is this something I’ll need to edit manually after updating Enfold or will this be addressed in the next version?

    Thanks again!

    #329885

    Hi!

    Seems to be an issue with the new version of LS and a particular kind of WP set-up, i’ll keep an eye on it.

    Best regards,
    Josue

    #330173

    after updating layer slider doesn’t work any more.

    http://led-professionals.de is empty expect menus etc.

    wp admin avia layout builder is trying to load templates endlessly…

    #330294

    Hi @paolos66!

    You are using Enfold 2.4.2, please update the theme to the latest version (3.0).

    Cheers!
    Josue

    #331006

    Have just updated to 3.0.1 and this still seems to be a problem.

    #331428

    Hey!

    @dogmut: Please refer to Josue’s fix here: https://kriesi.at/support/topic/layer-slider-enfold-3-0-not-working/#post-329400

    Best regards,
    Ismael

    #342803

    In /enfold/config-layerslider/LayerSlider/includes/slider_markup_init.php, line 36:
    $slides['properties']['attrs']['skinsPath'] = dirname(LS_Sources::urlForSkin($skin)) . '/';
    I tried to change this line with this
    $slides['properties']['attrs']['skinsPath'] = LS_ROOT_URL.'/static/skins/';
    and layer slider works but I don’t know why and if it’s correct

    #342840

    Hi!

    Yes that’s correct, LS_ROOT_URL it’s the theme path + /config-layerslider/LayerSlider.

    Best regards,
    Josue

    #345085

    i have tried changing slider_markup_init.php in http://www.padprinting.in
    still its not working
    silders show in ie11 but it doesnt show in chrome and firefox
    how do i troubleshoot my problem please help

    #345714

    Hi!

    @careprint: There are jquery issues reported on the console when I checked the site on Chrome. Please try to deactivate all plugins then test it again. As Josue suggested, please try to create a new slider then create a test page with the slider on it.

    Regards,
    Ismael

    #345725

    dear ismael
    i have tried disabling all plugins, creating a new slider and new page with the new slider
    check out http://www.padprinting.in/test
    i do not understand how its working in ie11 and not working in chrome and firefox
    i have disabled cloudflare and check that also
    what might be the problem?

    #346439

    @careprint: You forgot to activate jQuery. Thats your problem.
    Try to use the layer slider configuration “Use Google CDN version of jQuery”.
    test - Careprint • Learn the Art & Science of Pad Printing

    Why the problem issn’t fixed in Enfold Version 3.0.2?
    Its bad for windows users. Dont know if linux users have this problem, too.

    • This reply was modified 5 years, 1 month ago by  christmann_info. Reason: Added option in line 2
    #346954

    Hi!

    @Patrick: Thank you for sharing the fix. I hope it helps @careprint.

    @careprint: Please try @Patrick’s suggestion. If you enabled Rocket Loader (Asynchronous Loading of Javascript) on CloudFlare, it is the last option under “Performance Settings” tab, please disable because it tends to break the layer slider.

    Cheers!
    Ismael

Viewing 30 posts - 1 through 30 (of 48 total)

The topic ‘Layer Slider Enfold 3.0 Not Working’ is closed to new replies.