Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #652378

    I installed the premium “Enfold theme” few days ago on our website ( and updated to WP 4.5.3 in the meanwhile. I didn’t doublecheck if the “Launcher: Coming Soon & Maintenance Mode” plugin was still working as it as always worked like a charm before changing the theme.
    I have been warned today by some partners and customers that our website is public (launcher not showing up) and our cosmetic brand can’t afford to miss it’s launch a few days before the planned date! We really need to use the countdown timer and the mailchimp subscriptions features on a clean “coming soon” page while we are working on the site.

    Can you tell us if you are aware of any issue related to the WP 4.5.4 update or the launcher plugin?
    Our developer found out that launcher is well loading but mysteriously not displayed, maybe because of a too low level of request compared to the theme.

    Thanks for your support,
    Arsène Lesueur


    Hello, my developer found a workaround by adding the filter below :

     add_filter( 'template_include', 'override_wplauncher_options', -1000000000000000000000);
    function override_wplauncher_options($template)
            global $wp_launcher;
            return $wp_launcher->launch($template);

    I guess this is not a permanent fix but I hope it’ll help improving your product.



    Hi Arsène,

    Great, thanks for sharing that. Not sure if you need any more help though?

    Best regards,


    Hmmmm. I guess that my solution is only a temporary workaround and that I’m not the only one to experience this king of issue with maintenance plugins due to the really high levels of requests generated by the Enfold theme.

    You might consider digging a little bit for further improvements of the theme ;-) .



    Have you considered to make a maintenance page, using enfold and use that page after as homepage.
    You can still work on the backend, without people actually see the work.

    That way, you keep the site low on plugins and make your life easier!

    Let us know if that works better for you

    Best regards,


    I red that on your suggestions on other topics. This would be nice for a little blog but we are launching a cosmetic brand and can’t afford having any unwanted visitor. Especially because some payment plugins are already enabled on our Woocommerce, plus, we are using several accesses by user roles and really need to work on the whole customer funnel, starting from our real homepage.

    Sadly, we need to use a bunch of plugins that are slowing down our website but we compensate by a great server and some fine tuned caching tools. WordPress isn’t known for being really “lite” as an e-commerce platform.

    Best regards,
    Arsène Lesueur



    Plugins and custom scripts are common on a WordPress installation and it do affect page load. Aside from having a good server, you can improve page speed by doing the following:

    1. Optimize all images with AI/Photoshop before uploading to server ‘save as web safe’ jpg.
    2. Once all images are on the website, optimize with www optimizer plugin twice 1hr 10mins apart.
    3. Install wp-smushit run once to remove jpeg extra data then uninstall.
    4. Use BWP minify plugin to minify scripts and stylesheets, you can also use W3 Total Cache’s minify settings but we use BWP for Enfold.
    5. Install W3 Total Cache or WP-Super cache, select all recommended settings.
    6. Logout your website, visit every page at least once to create super cache files.
    7. Join Cloudflare setup your website on their CDN, Choose options: Full CDN Optimisation save then activate purge files. Once done log out.
    8. Have a cup of coffee.
    9. Visit your site after 20 minutes or so.
    10. Don’t forget to smile.

    Related links:

    Best regards,

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.