Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #28510

    I’ve a blog with the Grid layout and multiple pages. But instead of three only only one post is displayed in the last row. As can be seen on the Enfold demo page, the last row shows three posts. How can this be fixed?



    Please configure the Blog Posts element. How many posts did you set on “Post Number”?




    It is not a page element – if I understand you correctly – but the Blog page. As set in Theme Options > ‘And where do you want to display the Blog?’ and at Theme Options also, I’ve set at General Settings > ‘Blog Style’ : Grid Layout. Or is it possible to set the Post Number in the Theme Options?


    The number of posts per row depends on the total number of posts. If you have i.e. 9 posts Enfold will display 3 posts per row if you set the column setting to “3” (like here: ). However if you’ve a total number of 10 posts Enfold will display just one post in the last row – even if you set the column setting to “3” simply because there’re not enough posts for the last row (like here: ).


    Ok, I understand. I think than it would display 12 posts on the first page. That is four times three posts per row. But at the moment it displays three rows with three posts and one post at the last row. On the second page, it also has one post in the last row. the third page has the remaining six posts.

    At the moment it isn’t showing three posts in the last rows: Any suggestions?



    Please try following;

    1) make sure you have chosen Grid Layout as your Blog Style in Enfold theme options page

    2) go to Settings > Reading choose “Static Page” in “Front Page Displays” and for “Posts Page” choose your blog page.

    3) Change the number in “Blog page shows at most 10 posts” to 12 and Save changes.

    4) Check if it’s working, it should, then you can choose “Your latest posts” for “Front page displays”




    Ah, it is that easy! It works, thanks for the support!

Viewing 7 posts - 1 through 7 (of 7 total)
  • The topic ‘Last row of Blog Grid layout’ is closed to new replies.