Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #241876


    We’ve two languages running at the site, and are using WPML to manage the languages. Prior to upgrading the theme to 2.6.2, the language switcher icons were positioned on the top nav bar, to the right. However after the upgrade, while the English version of the site still has the language icons aligned correctly to the right, the Chinese version has these icons next to the social icons on the left.

    Is this a configuration issue or a bug?

    Many thanks!

    This reply has been marked as private.


    Maybe try to re-save all theme settings and make sure that you save the “Chinese” settings and the “English” theme settings. Use the language switcher in the admin bar to switch between the different theme settings. If this doesn’t help place following code into the quick css field (Chinese theme settings):

    .av_secondary_right .sub_menu {
    float: left;

    Best regards,

    This reply has been marked as private.


    I followed your instructions but still the same.

    1. is it “float: left;” or “float: right;”? After I placed in custom.css, even the English version has the top bar aligned to the left while it supposed to align to the right.
    2. I added a secondary menu to both languages, each has it’s own Login/Register links. However, only the English version has the secondary menu displayed correctly, aligning to the right. While the Chinese version only has the language switcher aligning to left, and sits next to the social media icons. I don’t even see the Chinese version secondary menu show up on the top.




    I checked the website on both language and the language switcher sits on the right of the top bar next to the top menu. I think it is fixed now. Remove browser cache then reload the page a few times.



    Thanks, it’s working now!

Viewing 7 posts - 1 through 7 (of 7 total)
  • The topic ‘Language icons not positioned correctly in the top nav bar’ is closed to new replies.