Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #173532

    HI there

    All of a sudden I’m having issues with javascript on the Edit Page in the wordpress backend.

    Neither the “Add media”, “Advanced Layout Editor” nor the Gravity Forms “Add form” button are working — the browser console gives the error:

    [Error] Error: cannot call methods on sortable prior to initialization; attempted to call method ‘toArray’
    error (jquery.js, line 3)
    (anonymous function) (jquery.ui.widget.min.js, line 4)
    each (jquery.js, line 3)
    each (jquery.js, line 3)
    (anonymous function) (jquery.ui.widget.min.js, line 4)
    (anonymous function) (postbox.min.js, line 1)
    each (jquery.js, line 3)
    each (jquery.js, line 3)
    save_order (postbox.min.js, line 1)
    place_top (avia-builder.js, line 121)
    set_up (avia-builder.js, line 104)
    AviaBuilder (avia-builder.js, line 93)
    (anonymous function) (avia-builder.js, line 1303)
    c (jquery.js, line 3)
    fireWith (jquery.js, line 3)
    ready (jquery.js, line 3)
    q (jquery.js, line 3)

    I’ve tried disabling plugins and note that this does not happen on the Edit Post or Edit Porftolio screen, just the Edit page screen.

    I see this issue has arisen in these forums previously but no real fix was given, apart from updating wordpress, which I’ve tried.

    I’ve turned off all caching and deleted all caching plugins and caching folders on the server.


    No after updating from 2.1 to 2.3.2 and activating my child theme again, Enfold is now showing the Blog as the Front page even though my theme options are showing my page “Homepage” as set as the Frontpage.

    If I go to edit the homepage the Advanced Layout Builder won’t load the page contents, the ajax progress indicator just spins and spins.

    The site is feeling quite broken and again the Browser Console is showing the same javascript error as above.



    Have you tried switching to a default theme? Please test it on a different browser.

    Best regards,


    If I switch to the 2013 Theme, “Add Media” and “Add Form” buttons work.

    If I switch back to Enfold, I lose this functionality, plus the Advanced Layout Button doesn’t work, plus the setting for Frontpage does not carry.


    Ah, upon noticing that the Yoast SEO fields weren’t properly displaying on the Edit Page screen, I deactivated that plugin and I can now access the Advanced Layout Builder, Add Media and Add Form functionality.

    So it seems that it is a conflict with the Yoast SEO plugin!

    However I still can’t set my home page as the “Frontpage” — it is persisting to the blog page despite changing this setting. No matter what I do here, I can’t set my homepage as the Frontpage.


    Am still stuck on trying to set my homepage as the Enfold Frontpage. This is a separate issue to the one caused by the plugin conflict above.



    There shouldn’y be any conflict with Yoast at this point as there has been some built in support to make sure it works so you might want to try re-downloading the theme and then re-installing with the fresh files over FTP. See: https://vimeo.com/channels/aviathemes/67209750

    For the home page, go to the WordPress Settings>Reading and make sure the option is “Your Latest posts”.



    I’m running the latest version of WordPress, Enfold and Yoast and as soon as I activate Yoast SEO, I get the above javascript error which blocks me using Advanced Layout Builder, the Add Media and the Add Form buttons. As soon as I deactivate Yoast, these functions all work again.

    As for setting the frontpage, I’m setting it to a static page “Homepage” — I’ve stipulated this in both the WordPress and Enfold settings and it still displays latest posts. No matter what page I specify in the Enfold settings, it only now displays the latest blog posts.



    Can you please send in the login details or post it here as a private reply?

    You can email it to //….

    Include the word “Kriesi” on the subject. Add the link of this thread on your email.

    Best regards,


    Those details have been sent — any clues on this would be greatly appreciated! This is a live site and it’s causing all sorts of problems and I don’t know the way forward right now.

    This reply has been marked as private.


    You have a lot of plugins installed. Have you tried deactivating one of them except for the Yeost SEO plugin? I don’t want to ruin any settings that you set on any of the plugins. Maybe a combination of plugins is causing the issue.



    Do you think that is why the homepage is no longer coming up as the front page? We just can’t see our homepage and this is a separate issue to the issue that the Yoast plugin was causing.

    There were 2 issues: “advanced layout builder” not displaying, and this I narrowed down to Yoast Seo — it was always working until I installed that one.

    But the big issue is that we can’t set a fixed page as the front page — we have a carefully laid out page but the Enfold settings are not carrying through. We are seeing a totally unrelated page, an archive page of Events instead! I have no idea why that page is coming up as the home page! No where is it set to display that way.


    I’ve disabled many of the plugins but the homepage issue still exists. It was working fine and the plugin status is now reverted back to the time where it was working OK. This is a very minimal plugin setup now, 6 are active

    I’ve tried changing the WordPress Reading settings and the Enfold theme frontpage settings but it still persists as the “Events” page.

    • This reply was modified 4 years ago by  bongoman.
    • This reply was modified 4 years ago by  bongoman.

    Ah, I’ve finally worked it out, nothing to do with Enfold, and as suspected, a plugin conflict — the issue was with the Modern Tribe “Events Calendar” plugin. It seems that an update to this plugin turned on a setting “include Events in blog stream” so somehow this setting was overriding everything else and all I was seeing was a stream of their custom post types instead of my specified home page.

    Issue is resolved but will leave this solution here in case anyone else comes across it.

    • This reply was modified 4 years ago by  bongoman. Reason: Updated to reflect resolution of issue
Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Javascript error on "edit page": Uncaught Error: cannot call methods on sortable’ is closed to new replies.