Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
  • #26431

    I know this may fall under the realm of not supporting third party plugins, but this is a pretty major conflict.

    I noticed this morning that no JS features were working in the WP admin’s Add/Edit Posts pages (though oddly not Add/Edit Pages). No dragging and dropping or minimizing meta fields, no Add Media lightbox, and so on. Usually a sign of a JS conflict. I spent a while trying to figure out what plugin or custom theme code might be causing it, and arrived at Simple-Press forums. When deactivated, the admin page behaved fine. Then, for good measure, I changed the site theme from Enfold to TwentyTwelve, with Simple-Press forums activated, and again the admin page proceeded to work perfectly.

    From what I can gather after doing my best to audit the source code from both working and non-working versions, this may have to do with the order in which Enfold JS scripts are queued in the code. This is hard to be sure of, as there is a lot of inline code as well, not just queued JS files.

    I’m happy to give you login information to this installation so that you can look around. Any help here would be immensely appreciated. We’re also in a pretty tight pinch with doing site updates and would happily compensate your team for any help looking into this.




    Please create me a wordpress admin account and send me the login data to: (Email address hidden if logged out) – I’ll look have a short look at it.




    Sent! Thanks, dude.


    Actually it’s the same error which was already reported by another user: (Purchase code hidden if logged out) -page and Kriesi will look into it. I forwarded your login data to Kriesi – maybe it helps him to find the error.


    Thanks for the update, Peter.


    Strange part of the page builder that I don’t recall encountering when I’ve used this theme on other sites is: the javascript dragging/dropping functions work with the meta boxes on the Add/Edit Page itself, butwithin the Layout Builder they do not. No dragging and dropping existing elements around, no dragging new elements from the list at the top. I can, however, click one of those new elements to have it appear at the bottom of my layout, and then suddenly everything can be dragged/dropped normally. Very strange.



    Looks like the issue has been fixed here: (Purchase code hidden if logged out) -page




    Thanks for the heads up, Ismael. I Re-Installed WordPress 3.5.2 and none of the symptoms of this bug have changed or disappeared.



    Please download a fresh version of the theme if you arent using version 1.81. Also boost your wordpress memory to 128M (Purchase code hidden if logged out) /




    Upgraded from Enfold 1.8 to 1.81.

    Added this to my wp-config.php file:


    define(‘WP_MEMORY_LIMIT’, ‘256M’);

    My php.ini file is also set to: memory_limit = 256M

    I did set it to 128M initially, and doubled it just in case.

    Unfortunately, the problem persists.


    This seems to be affecting the Edit Media panel in the admin as well.


    Hi Jan Bosman,

    What is the url for your site?

    If you have any other plugins or drop ins active try disabling them completely and then trying things out again. Also try using a different browser in case there is a browser extension or some local cache causing an issue.





    As stated in the original post, I already know what the plugin conflict is. Simple-Press forums. Firebug indicates that jQuery itself fails to load with Enfold and the forum plugin both activated:

    Error: cannot call methods on sortable prior to initialization; attempted to call method ‘toArray’

    [Break On This Error] “…eturn t?u.length:u?nt.error(e):L(e,a).slice(0)}function at(e,t,r){var i=t.dir,s=…” – jquery…r=1.8.3 (line 2)

    Dude has login details for this site. The URL is Log in to the admin and Add New Post – then try dragging around any meta boxes, using screen options, or adding media. Nothing.

    This happens regardless of browser (FF, Chrome, IE, Safari).


    I’m not familiar with the plugin and it isn’t on the WordPress plugin repository that I can see so it isn’t something we could easily look through to try and find the conflict.

    Your best route if the plugin is absolutely needed would be to check with the simple-press support and see if they have a standard fix for something like this. The theme doesn’t really load in jquery in an abnormal way or do anything overly complicated and the simple-press site only references some authors pulling the jquery libraries from google instead of wordpress core which isn’t any help here.

    The reason I asked for the URL is that the one above forwards to which isn’t using Enfold.


    Our site is a private membership site, hence the redirect. The admin account that I created for Dude is a way around that.

    I’ve submitted a ticket to the authors of the plugin in question and am awaiting their findings. I’ll post them in this thread when I hear back.


    We don’t have a group access to login details or anything but hopefully the plugin author is able to at least point in a good direction.

    #130401 (Purchase code hidden if logged out) /

    They did a great deal of digging, but still haven’t quite found the cause.

    Currently waiting on an update of Enfold compatible with WP 3.6 – I suspect upgrading WP versions may help.



    We released the update (v1.9.1). Please check if it works now.




    Hello Dude,

    I’ve updated to Enfold 1.9.1, WordPress 3.6, and the latest version of every other damn thing.

    The bug is still present.

    Did you get a chance to review the thread I linked in my last post?


    Can you please send me the ftp credentials. Kriesi and I can’t reproduce the bug on our servers and we need to debug the issue on your server. This is not possible with the default theme editor.

    Did you get a chance to review the thread I linked in my last post?

    No, because it seems to be locked for persons who don’t have a valid membership. I’ll contact the simple:press developers and ask them if they want to give us a membership account. Probably the support forum would also make it easier for us to sort out any incompatibility issues with simple press.



    Finally found the problem. Will be fixed with the next update wihch is coming soon ;)

    Best regards,


Viewing 21 posts - 1 through 21 (of 21 total)

The topic ‘Javascript conflict on Add/Edit posts pages’ is closed to new replies.