Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1180919

    Hi Guys,

    I’m having an issue with Enfold v4.7.2 with the Google ReCaptcha elements. I have noticed similar threads on the support forums but Victoria advise I should open a new thread to discuss my issue.

    Error message received while using Google Recaptcha v3 (with v2 as fall-back).
    “Invalid form for reCAPTCHA sent.
    Form could not be submitted. Please reload page and try again.
    Name for token field was missing.”

    I’ve tried Ismael’s fix of Enabling Performance File Compression but unfortunately, this has not fixed the issue.

    When removed and defaulting to the Enfold maths question (3+0=?) the form seems to be sent fine.

    Any advise/help would be great, thanks.

    .mint

    • This topic was modified 4 years, 5 months ago by mint.
    #1181959

    Hey mint,

    Thank you for the inquiry.

    It’s not working because the Enfold > Privacy & Cookies > Default Cookie Behaviour is set to the third option, which means that services such as the spam protection or recaptcha will only work once the user accepted or consent to the cookies. You should set the behavior to the first option so that all third party services are enabled on page load.

    Best regards,
    Ismael

    #1182974

    Hello and good morning!
    Unfortunately I have had the same problem on many websites since Enfold 4.6:
    – I chose the first option at – Enfold theme options> Privacy & Cookies> Cookie Handling
    – Enfold theme options> Performance and disable compressing CSS and JS files
    – use a cache plugin (Comet Cache or WP Fastest Cache)

    Tried and tested everything possible, I noticed the following:
    – the problem apparently only exists with slow internet connections (G3), with WiFi and G4 it works
    – it apparently affects Google reCaptcha V3, reCaptcha V2 has at least just works with G3

    After many installations (> 20) affect me, I get a lot of feedback that the contact form is not working correctly, error message:
    Sorry, a problem occured trying to comunicate with Google reCaptcha API. You are currently not able to submit the contact form. Please try again later – reload the page and also check your internet connection.

    Reload the page does not bring anything :-( Please help, because if you deactivate Google recaptcha the spam emails are unbearable for some installations!

    Thank you,
    Regards, Soltner

    #1182977
    This reply has been marked as private.
    #1182984

    If you would like to use the contact form (en) for test purposes, I have set the recipient address on my own.

    #1183002

    Thanks Ismael for your suggestion. However, can I ask do you know would your suggest be a valid option for GDPR and ICO cookie control guidelines/rules?

    Thanks,
    .andy

    #1183333

    Hi,

    Setting it to the first option is fine as long as the users are notified that the cookies are required to enable certain services or functionality in the site and that they have an option to disable them manually if they want to. You can also provide instructions on how they can control cookies in their browser in a dedicated cookie or privacy page. A good example of a cookie consent message can be found directly in the ICO site. Here’s what their cookie consent widget says.

    Necessary cookies
    Necessary cookies enable core functionality such as security, network management, and accessibility. You may disable these by changing your browser settings, but this may affect how the website functions.

    The cookie control instructions can be found here: https://ico.org.uk/your-data-matters/online/cookies/

    @soltner: Thanks for chiming in. How do you test or simulate the connection speed? Are you throttling it from the browser? Please create a new thread/ticket so that we can check the issue separately.

    Best regards,
    Ismael

    #1183391

    Thanks Ismael. Happy for this to be closed if needs be.

    Thanks!

    #1183551

    Hi mint,

    Glad we could help :)

    If you need further assistance please let us know.
    Best regards,
    Victoria

Viewing 9 posts - 1 through 9 (of 9 total)
  • The topic ‘Invalid form for reCAPTCHA sent.’ is closed to new replies.