Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #176492

    Installed wp and enfold theme by ftp, increased the allocated php memory to 128M,
    and every time when I try to activate the theme, I get this error:

    Fatal error: Maximum execution time of 180 seconds exceeded in /home/…/docs/wp-includes/compat.php on line 0

    if I reload the page, error again:

    Fatal error: Maximum execution time of 180 seconds exceeded in /home/…/docs/wp-includes/compat.php on line 30

    Please help!


    Hi kaufman-agency!

    Try adding this too:
    ini_set('max_execution_time', 300);


    This reply has been marked as private.


    What is the hosting provider? I’m not even able to get access to the site as the connection just times out. I’ve installed Enfold on a number of budget hosters without issue though I have upped the memory on most of them where I could which helped get general stability up.

    You might also want to try deactivating any and all active plugins and dropins that are installed. A quick google on the error and it pops up with a number of plugins and various issues so I don’t think its necessarily a theme specific issue but a symptom of something else that is just getting triggered because of the theme.



    My hosting provider is http://nic.ru/en/index.html
    Please try again. I just tried, it works. No problems there, by the way, I have already few wp-websites there working fine.
    I have no plugins there. I’ve just installed WP and just trying to activate your template.
    And if you read my original message, I have also upped my memory.
    Kind regards, Irina



    It takes forever to load your website. I think you should upgrade your hosting services. Please install WordPress again from scratch then download the latest version of Enfold on your themeforest account.

    Best regards,

    This reply has been marked as private.
    This reply has been marked as private.


    Logged in and installed several debugging plugins. Unfortunately I activated the theme once before checking one last thing that I wanted to check with phpinfo and now cant deactivate it without ftp access: which version of php the server is running.

    The error message suggests that wordpress is trying to emulate a standard php function called “mb_substr” which is used by the theme. For some reason that function is not available on your server so wordpress uses the compatibility function _mb_substr in compat.php.

    The problem with this function, as is stated in the documentation: it only works for utf-8 encoded charsets. So it seems that the combination of the server not providing this function. Would you mind deactivating the theme once more and letting me know which php version the server is running?


    This reply has been marked as private.


    Unfortunately I am in no way a server settings expert. At this point I think its save to say that the problem is caused by an unusual/missing server setting but without a error message I have no idea where I could even begin to start with :/

    I tried to comment big junks of code for the last hour to try and find whats causing the problem but haven’t gotten any further. If the script aborts at any time due to a php error caused in the theme the error is shown as long as wordpress has not yet loaded the template files that display the html code. so for example if I echo a random string at the end of functions.php after the whole framework is already loaded it is displayed without problems. If I try to do the same in the index.php file in line 1 I get nothing.

    At this point I would guess that only changing some server settings can fix that problem but since I have not the tiniest clue what would cause this and also don’t want to mess with your server settings I can’t really offer any assistance with this :/


    Dear Kriesi,
    I found the problem – by default on my server Simple XML module was off. So I turned it on and everything started working!
    Thank you and best regards,

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Installed wp and enfold theme and got error’ is closed to new replies.