Tagged: , ,

Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
    Posts
  • #702686

    I’ve recently installed SSL on my site. Seems to work, but *all* pages appear in Firefox with the yellow warning tag over the padlock, with the message “Parts of this page are not secure (such as images).”

    Running a good number of pages through the whynopadlock.com check, it seems that none of my images in wp-content/uploads are secure. For example (from whynopadlock):

    Insecure URL: http://centerforworldmusic.org/wp-content/uploads/2014/06/logo_w_red_type_52.png
    Found in: https://centerforworldmusic.org/

    Insecure URL: http://centerforworldmusic.org/wp-content/uploads/2014/06/dark_brown_burlap_texture.jpg
    Found in: https://centerforworldmusic.org/

    I’d appreciate suggestions as to how to fix this.

    Thanks! Lance

    #703581

    Hey Webmaster,

    Thank you for using Enfold.

    You should install ssl plugins. Please try one of the following plugins.

    // https://wordpress.org/plugins/wp-force-ssl/
    // https://wordpress.org/plugins/force-ssl/
    // https://wordpress.org/plugins/really-simple-ssl/

    Best regards,
    Ismael

    #704449

    Thanks, Ismael, but none of these work. Still getting the message that the images are insecure.

    Number of insecure items: 2
    Insecure URL: http://centerforworldmusic.org/wp-content/uploads/2014/06/logo_w_red_type_52.png
    Found in: https://centerforworldmusic.org/
    Insecure URL: http://centerforworldmusic.org/wp-content/uploads/2014/06/dark_brown_burlap_texture.jpg
    Found in: https://centerforworldmusic.org/

    Are there other possibilities?

    #704450

    Ismael,
    I received this message from the website host (Flywheel):

    If the SSL Insecure Content Fixer plugin isn’t solving the issue for certain images, it means those images are hard-coded to HTTP. In other words, wherever those images are originally being called into the page—whether it’s in a setting somewhere in the WordPress admin area, in the theme customization, or a theme file—it’s specifically typed out as “http://”.

    You’ll need to find the source of that image—again, wherever it’s being pulled into the page—and either edit “http” to “https” *or* make the link a relative link instead of an absolute link (by eliminating everything before the first slash after “centerforworldmusic.org”).

    Do I have to edit the theme myself? Thanks!

    #704508

    Hi!

    If those images are been added from the theme options, you will have to replace them, as the images do not work with just a plugin tsllation.

    Thanks a lot

    Cheers!
    Basilis

    #705718

    Dear Basillis,

    I’m sorry but I don’t understand your advice. I’m not sure what it means to add images “from the theme options.” So far as I know, all of the images on our site have been added via the media library. Neither do I understand what it would mean to “replace them.” Does that mean delete them from the media library and upload them again?

    Here’s one example. Whynopadlock.com consistently says that the primary logo on the site is insecure, thus:
    Insecure URL: http://centerforworldmusic.org/wp-content/uploads/2014/06/logo_w_red_type_52.png

    However, when I look for this item in my media library, I find it at a secure (https) address:
    https://centerforworldmusic.org/wp-content/uploads/2014/06/logo_w_red_type_52.png

    Any further clarification and help you could provide would be appreciated.

    Thanks! Lance

    #706805

    Hi,

    have you got the same issue when using a default WordPress theme? please let us know about your results.

    Best regards,
    Andy

    #708768

    Sorry. I have a day job! :-)

    Do you have anywhere instructions for reverting to a default WordPress theme? Can I do this without screwing up the site permanently?

    Thanks! Lance

    #709160

    Hi,

    yes. Simply activate another (default) WordPress theme.

    Best regards,
    Andy

    #958235

    Hi
    Can someone help me out am setting up SSL I have a report that says

    1) An image with an insecure URL of “http://test.kriesi.at/construction/wp-content/uploads/sites/7/2015/10/ (Purchase code hidden if logged out) -1500×1085.png” was loaded online: 251 of https://asoisrael.org/.
    This URL will need to be updated to use a secure URL for your padlock to return.
    I have no idea how to figure it out.

    2) You currently have TLSv1 enabled.
    This version of TLS is being phased out. This warning won’t break your padlock, however, if you run an eCommerce site, PCI requirements state that TLSv1 must be disabled by June 30, 2018.

    TIA

    • This reply was modified 3 months ago by  Alhaji2017.
    #958236

    Hi
    Can someone help me out am setting up SSL I have a report that says

    1) An image with an insecure URL of “http://test.kriesi.at/construction/wp-content/uploads/sites/7/2015/10/ (Purchase code hidden if logged out) -1500×1085.png” was loaded online: 251 of https://asoisrael.org/.
    This URL will need to be updated to use a secure URL for your padlock to return.
    I have no idea how to figure it out.

    2) You currently have TLSv1 enabled.
    This version of TLS is being phased out. This warning won’t break your padlock, however, if you run an eCommerce site, PCI requirements state that TLSv1 must be disabled by June 30, 2018.

    TIA

    #959034

    Hi TIA,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Best regards,
    Victoria

    #959089

    hello

    • This reply was modified 3 months ago by  Alhaji2017.
    • This reply was modified 2 months, 4 weeks ago by  Victoria.
    #959625

    Hi Alhaji2017,

    Credentials did not work for me. Could you please update the credentials?

    Best regards,
    Victoria

    #968302

    Hi,

    I am also having this issue and I don’t know how to fix it. This issue occurred after I update the latest enfold child theme.
    There is a message showing while checking on WHYNOPADLOCK.COM
    <
    An image with an insecure url of “http://www.trianglehomeware.com/wp-content/themes/enfold/images/ctab-1.png” was loaded on line: 717 of https://www.trianglehomeware.com/.
    This URL will need to be updated to use a secure URL for your padlock to return.
    An image with an insecure url of “http://www.trianglehomeware.com/wp-content/themes/enfold/images/topbar.png” was loaded on line: 717 of https://www.trianglehomeware.com/.
    This URL will need to be updated to use a secure URL for your padlock to return.
    >

    Please help

    Enffie

    #968383

    Hi

    Me again.
    I just found that the issue just occurs when I active the ENFOLD CHILD theme. It is normal when I active Enfold or other default themes.
    However, I have to use Enfold Child as I have some customized CSS for the website.
    What should I do?

    Regards,
    Enffie

    #969921

    Hi Enffie,

    Please open a new thread and include admin login details to your site in private so that we can have a closer look.

    Best regards,
    Rikard

    #969943
    This reply has been marked as private.
    #970297

    Hi,

    Thanks for the feedback. How exactly are you adding them? If you added them manually then you will have to adjust the URL manually as well.

    Best regards,
    Rikard

    #970477

    Hi Rikard,

    Have you access to my website and check? I don’t know why it is not secure after I active enfold child theme.

    Regards,
    Enffie

    #971095

    Hi Enffie,

    I tried to access your site but I got this response:

    Access Denied - Sucuri Website Firewall

    Block reason: Your request was not allowed due to IP blocking (not white listed).
    Can you try to go to Enfold > General Styling > Quick CSS and find http:// you should be able to find 6 results, just replace them with https://. Hope it helps.

    Best regards,
    Nikko

    #982147

    I had the same problem for weeks and non of the above suggestions could work for me
    I have finally found a solution and hopefully it will work for you too.
    step 1
    navigate to your admin and add this plugin https://wordpress.org/plugins/ssl-insecure-content-fixer/#installation
    activate the plugin.
    step 2
    navigate to settings and select SSL Insecure Content Fixer settings
    from here you can play around with the settings the one that worked for me was selecting the fallowing
    Capture All
    List category posts with pagination
    WooCommerce + Google Chrome HTTP_HTTPS bug (fixed in WooCommerce v2.3.13)
    standard WordPress function
    then click save changes.
    now open 3 to 4 different bowers to check if everything is working correctly

    Thanks

    #983465

    Hi Vusi,

    Great, glad you found a solution and thanks a lot for sharing, much appreciated!

    Best regards,
    Rikard

Viewing 23 posts - 1 through 23 (of 23 total)

You must be logged in to reply to this topic.