Tagged: 

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #938315

    Hi,

    I have a site that has a clone in QA. In QA in the header I have a section that looks like:

    <!–
    Debugging Info for Theme support:

    Theme: Enfold
    Version: 4.0.7
    Installed: enfold
    AviaFramework Version: 4.6
    AviaBuilder Version: 0.9.5
    ML:128-PU:7-PLA:9
    WP:4.7.10
    Updates: disabled
    –>

    <style type=’text/css’>

    This is fine. However in production this same site with all the same settings has that plus an extra section that looks like this:

    <style type=’text/css’ id=’dynamic_styles’>

    In this section there is an immense amount of inlined styles, such that it bloats the HTML for the page considerably. It has been suggested by our SEO consultant that we remove this as this causes search engines to potentially calculate all our pages as having thin content (since the HTML:Text ratio is quite high) and decreases page performance.

    I’m having difficulty finding where this section is coming from, and why it would be different across two clones of the same site, and what it is doing since the pages appear the same on both sites even though one doesn’t have this section. There is no custom CSS defined on either of the sites. Can anyone point me to where this is generated from and potential solutions to remove it?

    Thanks!

    #938551

    Hey tayloed,

    I think that CSS is coming from the content in Quick CSS, could you try to move that content into one of the CSS files instead maybe?

    Best regards,
    Rikard

    #939338

    Thanks for the response @Rikard. Can you clarify where that would be? There is no CSS in the Additional CSS section on the customize appearance menu, nor is there any CSS in the Quick CSS section under the Enfold > General Styling menu. Is there another section where it may be lurking?

    #939679

    Hi tayloed,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Best regards,
    Victoria

    #939906

    @Victoria I’d prefer not to do that if possible. Can you give me an idea of what you would look at and I can verify myself? Thanks!

    • This reply was modified 6 years, 3 months ago by tayloed.
    #940667

    Is there anything else I’m able to check on my own without providing access to the site?

    #940741

    Hi,

    The site is still using an old version of the theme. Please upgrade to version 4.2.6 and toggle any options in the General Styling panel then save. This will regenerate, compress and merge the scripts and stylesheets.

    Best regards,
    Ismael

    #941536

    Hi @Ismael,

    In the Enfold settings it’s showing that the theme is up to date at 4.0.7 (see image here), and if I go to check manually I don’t see Enfold in the list of themes that has an update available. Is there a way to manually update, or something else I need to do? Thanks!

    • This reply was modified 6 years, 3 months ago by tayloed.
    #941808

    Hi,

    Please try to update manually via FTP: http://kriesi.at/documentation/enfold/updating-your-theme-files/

    Best regards,
    Rikard

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.