Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1310023

    Hi,

    I’m using WPML for a website in german and english.
    YOAST SEO Premium plugin had a compatibility problem with another plugin.
    The solution was to change the language URL format to language as parameter

    My problem now is, that I have several individual links in the main menu which don’t work anymore.
    So I changed the URL but the link goes to the german page instead of to the english layout element.

    First the individual link was

    after changing the URL format the link should be

    but doesn’t work

    I cleared cache a couple of times and I set an new individual link and changed the #nonmag to #nonmag_engl – still doesn’t work.

    Would you please help me?
    Thank you!

    Best regards
    Bettina

    #1310099

    Hey Bettina,

    Thank you for the inquiry.

    The query parameter lang should go after the anchor, so the correct URL should be..

    https://site.co.at/#nonmag?lang=en
    

    Best regards,
    Ismael

    #1310100

    Hi Ismael,

    thank you.

    I tried that before but both don’t work
    I also tried it with a / before the ?lang=en
    the individual link still returns to the german site instead of to the element on the same englisch page.

    Best regards
    Bettina

    #1310603

    Hi,

    Did you change back the language URL format to URL parameter?

    // https://wpml.org/documentation/getting-started-guide/language-setup/language-url-options

    We may have to access the site in order to check the issue properly.

    Best regards,
    Ismael

    #1313926

    Hi Ismael,

    I’m just back from vacation :D

    I had to change back the URL format to URL parameter otherwise links from english pages open german pages.
    And I deactivated the anchor links “Non-Mag Steel | Technologies | Business” in the main menu in the meantime because they open german pages instead of jumping to the proper content element.

    Best regards
    Bettina

    #1314961

    Hi,

    Thank you for the info.

    Looks like the ID of the section in the EN version is different. Try to use the following URL instead. (see private field)

    Best regards,
    Ismael

    #1317346

    Hi Ismael,

    thank you!!!!
    That works now.

    Best regards
    Bettina

    #1317606

    Hi,

    No problem! Glad to know that the solution works. Let us know if you need anything else.

    Have a nice day.

    Best regards,
    Ismael

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Individual Link doesn't work’ is closed to new replies.