Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #793987

    Hello
    Sometimes I’ve got http error when uploading images. This happens for about one image in six or ten.
    I’ve disabled all plugins and test. Few images upload http errors.
    I’ve disabled all plugins and Enfold theme. No http error.
    I’ve disabled Enfold theme and enabled all plugins. No http error !
    So it seems to be the enfold theme to cause image upload http errors…
    Could you take a look please ?
    Thanks

    • This topic was modified 7 years ago by romano2.
    #794011

    And the more the image is bigger in Ko, the more I’ve got http errors.
    But it occurs even with 1800px width and 200-300 Ko images…

    #794047

    Hi romano2,

    Could you enable WordPress debug mode (https://codex.wordpress.org/Debugging_in_WordPress), try uploading big images again and send us the error log?

    Best regards,
    Victoria

    #794055

    Ok, the only things to display on top of screen are that :

    
    Strict Standards: Non-static method MemberAccess::run() should not be called statically in /srv/data/web/vhosts/www.freesalsa.fr/htdocs/wp2016/wp-content/plugins/member-access/member_access.php on line 40
    
    Strict Standards: Non-static method MemberAccess::instance() should not be called statically in /srv/data/web/vhosts/www.freesalsa.fr/htdocs/wp2016/wp-content/plugins/member-access/lib/MemberAccess.php on line 81
    
    Notice: Undefined index: page in /srv/data/web/vhosts/www.freesalsa.fr/htdocs/wp2016/wp-content/plugins/members-list/core/search.php on line 30
    
    Notice: has_cap est appelé avec un argument qui est déprécié depuis la version 2.0.0 ! L’utilisation des niveaux d’utilisateur par les extensions et thèmes est désormais interdite. Utiliser les rôles et capacités à la place. in /srv/data/web/vhosts/www.freesalsa.fr/htdocs/wp2016/wp-includes/functions.php on line 4022
    
    Notice: get_bloginfo est appelé avec un argument qui est déprécié depuis la version 2.2.0 ! L’option home est obsolète pour l’ensemble des fonctions bloginfo(). Utilisez plutôt l’option url. in /srv/data/web/vhosts/www.freesalsa.fr/htdocs/wp2016/wp-includes/functions.php

    After bad upload, when “http error” appears, no more debug text is displayed…

    • This reply was modified 7 years ago by romano2.
    #794065

    And the problem wasn’t here with previous versions of Enfold…

    #794191

    Hi romano2,

    None of these errors are due to Enfold. These are not the errors we are looking for.
    There could have been configuration changes and/or your provider security or configuration changes.
    Which php are you running?

    Best regards,
    Victoria

    #794318

    Yop, I saw.
    So I’m running PHP 5.6 / MySQL 5.5 .
    Effectively, I changed the web hosting formula, from SimpleHosting S to SimpleHosting M (gandi.net).
    But the technical characteristics are quite the same. I will ask my hosting provider…

    #794328

    Sorry, I’ve done a lastest test, without Enfold, and the problem is here.
    So it’s not a specific a problem with Enfold. I will ask my hosting provider…

    #794445

    Hi,

    alright, let us know if we can be of any help concerning the theme.

    Best regards,
    Andy

    #794950

    Hi,
    I inserted the code below in functions.php, and it seems to work now, even with big images.

    add_filter( 'wp_image_editors', 'change_graphic_lib' );
    function change_graphic_lib($array) {
    return array( 'WP_Image_Editor_GD', 'WP_Image_Editor_Imagick' );
    }

    Can be useful for others…

    #794987

    Hi,

    Thanks for sharing the solution that worked for you :) It would surely help others and we appreciate it. Great Job :)

    Best regards,
    Nikko

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.