Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #199618

    Everything was working just fine when it suddenly stopped attaching properly images or setting as featured.

    Actually there are the following certain symptoms:
    -When creating a new post:
    1.via the add Media button process i select and upload a new image with the thumbnail showing properly and when i press insert into post/insert gallery a blank media box appears in the post’s textbox.
    2.when i try to set a new featured image (one that is newly uploaded or one of the old images) the bottom right ‘set featured image’ widget looks like no image is selected or set. I click “set as featured image” and the modal closes but the image never appears.
    -When I try to browse my Media>Library any newly uploaded image is blank with no thumbnail available and no image file appearing when clicking view (via the ‘domain/?attachment_id=…’ link).
    -When browsing my ftp server directory or typing the url ‘domain/wp-content/uploads/2013/3/image.jpg’ the images are appearing just fine.
    -Any images that I upload I can see in the media browser but their thumbnails there aren’t cropped like normal, it’s a thumbnail of the entire image where normally (and previously uploaded images) it’s cropped. They also don’t have pixel dimensions listed like other images do.

    This is causing a major problem on a busy e-commerce site. I’ve seen others with the same issue who said it was fixed when they disabled the “Advanced Custom Fields” plugin, but I don’t have that plugin.

    I did not make any changes to anything, no new plugins, no updates. It worked fine in one product listing, then I went to the next one and it stopped and now won’t work for any.

    I’m wondering if the advanced custom fields plugin or something similar is integrated into the theme and could be causing this strange issue.


    Hi Vincent!

    If you didn’t alter any plugin/theme/wordpress files and you didn’t install any new plugins it might be a problem with the database (i.e. a corrupt database entry can cause this issue(s)). Did you try to restore a backup of the database? Maybe try to restore a backup of your website on a test server and check if the problem is solved if you use the backup. It’s strange that “suddenly” the featured images don’t work anymore especially because the code will always produce the same result if you didn’t modify it. Imo the only variable component here is the database data which may change based on the user input.

    Best regards,


    Hi Peter,
    You’re absolutely right. I spent the better half of the day trying to figure it out before finally doing a database table repair (twice) and rebooting my mySQL container, whcih fixed it. Thank you for responding to my post, even though it was not an issue with the theme.

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Image Upload/Featured Images suddenly stopped working’ is closed to new replies.