Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #806821

    I changed my host and now the icons are missing on my website.

    My .htaccess looks like this

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    # Wordfence WAF
    <Files ".user.ini">
    <IfModule mod_authz_core.c>
    	Require all denied
    </IfModule>
    <IfModule !mod_authz_core.c>
    	Order deny,allow
    	Deny from all
    </IfModule>
    </Files>
    
    # END Wordfence WAF
    
    <FilesMatch "\.(ttf|otf|woff)$">
    <IfModule mod_headers.c>
    Header set Access-Control-Allow-Origin "*"
    </IfModule>
    </FilesMatch>

    here’s my site: http://www.yinyangbangers.com

    #806891

    running the latest version of wordpress and enfold!

    #806993

    What do you mean by : I changed my host
    you are still behind an apache server?

    are you now using a cdn?

    #807035

    jap still behind an apache server, just a cheaper option, which has more of what i need.

    also the icons aren’t working inside enfold:

    #807127

    maybe ( you now best your domains ) try this instead of wildcard asterix in htaccess:

    <IfModule mod_headers.c>
        SetEnvIf Origin "http(s)?://(www\.)?(domain1.org|domain2.com)$" AccessControlAllowOrigin=$0$1
        Header add Access-Control-Allow-Origin %{AccessControlAllowOrigin}e env=AccessControlAllowOrigin
        Header set Access-Control-Allow-Credentials true
    </IfModule>

    if only for font :

    <FilesMatch "\.(ttf|otf|woff)$">
    <IfModule mod_headers.c>
        SetEnvIf Origin "http(s)?://(www\.)?(domain1.org|domain2.com)$" AccessControlAllowOrigin=$0$1
        Header add Access-Control-Allow-Origin %{AccessControlAllowOrigin}e env=AccessControlAllowOrigin
        Header set Access-Control-Allow-Credentials true
    </IfModule>
    </FilesMatch>

    some people which are behind only https tells that the code must be edited a bit to:

    <FilesMatch "\.(ttf|otf|woff)$">
    <IfModule mod_headers.c>
        SetEnvIf Origin "^http(s)?://(www\.)?(domain1.org|domain2.com)$" AccessControlAllowOrigin=$0
        Header add Access-Control-Allow-Origin %{AccessControlAllowOrigin}e env=AccessControlAllowOrigin
        Header set Access-Control-Allow-Credentials true
    </IfModule>
    </FilesMatch>
    #807158

    so should i just insert my one url here like this?

    <IfModule mod_headers.c>
        SetEnvIf Origin "http(s)?://(www\.)?(yinyangbangers.com)$" AccessControlAllowOrigin=$0$1
        Header add Access-Control-Allow-Origin %{AccessControlAllowOrigin}e env=AccessControlAllowOrigin
        Header set Access-Control-Allow-Credentials true
    </IfModule>
    #807208

    Hi,

    I’m not sure if that would work, did you try it out? Maybe it would be better if you contacted the host to see if they can help you out?

    Best regards,
    Rikard

    #807271

    on stackoverflow: (Purchase code hidden if logged out) -origin-domains”>https://stackoverflow.com/questions/1653308/ (Purchase code hidden if logged out) -origin-domains

    from the security point of view this might be the better method – because only your domains are allowed to access cross-site content

    if you only have the one url i would try this:

    <FilesMatch "\.(ttf|otf|eot|woff|woff2|sfnt|svg)$">
    <IfModule mod_headers.c>
        SetEnvIf Origin "^http(s)?://(www\.)?(yinyangbangers.com)$" AccessControlAllowOrigin=$0
        Header add Access-Control-Allow-Origin %{AccessControlAllowOrigin}e env=AccessControlAllowOrigin
        Header set Access-Control-Allow-Credentials true
    </IfModule>
    </FilesMatch>

    if you will see a white page – you can allways get rid of that entry and try different options.

    #807334

    I contacted them and they weren’t able to help me with this issue, they said it’s a problem with the theme.

    @guenni007: Unfortunately this did not solve my problem:

    <FilesMatch "\.(ttf|otf|eot|woff|woff2|sfnt|svg)$">
    <IfModule mod_headers.c>
        SetEnvIf Origin "^http(s)?://(www\.)?(yinyangbangers.com)$" AccessControlAllowOrigin=$0
        Header add Access-Control-Allow-Origin %{AccessControlAllowOrigin}e env=AccessControlAllowOrigin
        Header set Access-Control-Allow-Credentials true
    </IfModule>
    </FilesMatch>
    #807384

    usually when this error occurs, the icon don’t show up in the frontend but this time, it’s not working inside the dashboard as well. I even tried downloading new fontello fonts but they didn’t work either

    #807424

    nvm i fixed it!

    #807440

    Hi,

    Great, glad you got it working. Please let us know if you should need any further help on the topic or if we can close it.

    Best regards,
    Rikard

    #807462

    please tell us how if it was a fix with common interest. Maybe we got the problem once too.

    #807467

    In my wp config file this is how the url was set:

    define('WP_HOME','http://www.domain.com');
    define('WP_SITEURL','http://www.domain.com');

    so I clicked on the boxed icon and went into inspect > console and it was www.domain.com there. so just had to remove “www” and it worked.

    https://crunchify.com/ (Purchase code hidden if logged out)(Purchase code hidden if logged out)(Purchase code hidden if logged out) -maxcdn/

    #807788

    Hi @thatkidaathi,

    Thanks for sharing, much appreciated :-)

    Best regards,
    Rikard

    #808068

    why is in your wp-config.php such an entry? These settings were normaly made via Dashboard – Settings – General !
    And didn’t i ask if you are using a cdn? – Nevermind – nice that you got it.

    #808071

    We’re glad that you got the solution! Please let us know here in the forums if you need further help with anything else.

    Best regards,
    Sarah

Viewing 17 posts - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.