Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
  • #294930

    Hi guys

    I’ve bumped into so many things already, and foud solutions in the end. This time, I’m just too non-techy to understand even where to begin. There’s an error message on top of my website, on each page. It says Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /srv/hchcur/www/ in /srv/hchcur/www/ on line 33

    You can see it happening here – – and it’s been there since I opened (and moderated, but not really) the functions.php file that’s in wp includes (!) on the server. I didn’t know where to add a certain piece of code. So I tried it over there, then removed it again, and the error message has been there ever since.

    Can you guys help me out what I can do to fix it? Thanks in advance!!


    Hi briefencv,

    In case your core WP install doesn’t have custom code, I’d advice you to simply go into WP admin > Dashboard > Updates > Click: “Re-Install Now”. That should get your WP install back into its original state. Re-Install does the same as when you update WP from the admin area, so no need to fear it overwrites anything other than the core files.

    In case you’ve custom code in your WP install: I’d just download the latest WP package, extract it and then upload its functions.php to the server.

    Hope this helps.

    Kind regards,


    PS: Nice Enfold customizations!


    Thank you, Ralph!

    For both the quick and insightful Reaktion, und das Kompliment :)

    I’ll try in an hour. Sounds pretty easy… Thanks!!


    You’re welcome and I hope it works!

    Kind regards,




    Please refer to Ismael’s post here –

    Thanks Ralph :)

    Best regards,


    Hi @Yigit

    I followed those steps. The error msg is gone. Yet, it got replaced by a new one.

    Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /srv/hchcur/www/ in /srv/hchcur/www/ on line 506

    I’ll reverse what I just did and try the reinstall possibility Ralph came up with. Will be back in a flash…


    lol @ralph12 – now the error message has found itself a new species:

    Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /srv/hchcur/www/ in /srv/hchcur/www/ on line 33

    Which does give me hope: looks like it’s now nearly a near match with the message as on Ismael’s post. Here’s trying that trick again! Adjusting the main (!) Enfold functions.php file I reckon. Not the one in WP-includes.

    …ahmmm… nope. That results in:

    Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /srv/hchcur/www/ in /srv/hchcur/www/ on line 506

    Guys? Am I looking in the wrong place? Didn’t I simply incorrectly modify (even though I tried not to – just added some and deleted the same thing 5 minutes later) the WP-includes functions.php file? -I don’t even know what’s in that WP-includes folder :’) Shoot me.



    Let me add this too – for I don’t know how influential this could be:

    This website – – was first completely set up at a subdomain – Sunday/Monday I moved the old website, and put this one in its place, following codex.wp guidelines. So, in the WP settings I typed the new address, and after that, went on to copying/moving the WP files in FTP, into the new root (from subdomain to main domain). The old site being a Joomla site is still (asleep though) on that server, and its MySQL (4) database is still alive. The new site logically built up its own db (5) stuff when still in the other, temporary, location.

    I live with the assumption this is all okay: this should simply work. Right? The WP codex-instructions made me believe it would. I’m now doubting whether the error could lie somewhere in this part of the story. If you, reader, are pointing to your forehead, please tell me how stupid I am.

    Tried one more thing just now: deactivating Enfold, and reactivating it again gives me this output, in the WordPress admin area (!) :

    Warning: Cannot modify header information – headers already sent by (output started at /srv/hchcur/www/ in /srv/hchcur/www/ on line 530

    …so I’m pretty much lost in the woods… :$ I’d really appreciate the help, guys. Thanks in advance!!


    In the mean time… ;)

    I replaced all the files in FTP with the files I backup’ed two days ago. This is much worse. Not just AN error on top of the website, but a fatal error and as such:

    Warning: require(/srv/hchcur/www/ [function.require]: failed to open stream: No such file or directory in /srv/hchcur/www/ on line 76

    Fatal error: require() [function.require]: Failed opening required ‘/srv/hchcur/www/’ (include_path=’.:/var/php5/lib/php’) in /srv/hchcur/www/ on line 76

    So I’m undoing right now what I just did, replacing all the files with what I just backup’ed 20 mins ago, in the mean time trying to get my heart beat down from 180 to 60-100 again.


    …and now I just found out the entire FTP backup I made an hour ago is NOT an entire FTP backup. There’s not even a themes folder in FTP right now. Not even an empty one. So selecting all by hand in Filezilla had some selective devil hidden in it. (wtf……..)

    Oh lord. Now I’m even much much further lost than I ever was with the error notices. I should have stopped and waited for you guys. Stupid. And seriously, no idea why on earth such a backup (selecting all and copying to hard drive – I mean come on :$ ) would go wrong. Ever.

    And just now the story turns out just fabulous: even the 2 days ago FTP backup has e.g. NO themes folder in wp-content.


    This is called being screwed. Thanks to being technical nobody… Oh boy, how I hope someone is coming to check out this thread before the evening is over… I’m pretty lost.


    Wow… Well… This is a very clear hint:

    Full FTP backups from days ago and earlier today are both like 30MB. IN TOTAL! This can never be right. This is pretty wrong. And makes absolutely no sense to me. Other WP sites I’ve built are more like 150MB. How on earth, why on earth would FileZilla or the webhost have me copy only 20% of all files and give me some notice? :$

    Do close this thread if you’re sick of my wining ;) …imma go drink some wine now :'(



    I checked your website and it seems you managed to fix the header errors. May I ask how you did it?

    Also, I remember I’ve had similar header errors once… they are very tricky as they can point you in a completely wrong direction. In the end, on my WP install, they were caused by a plugin the error message didn’t mention. Disabled the plugin; error gone.

    When getting errors on a clean WP install using a quality premium theme, it’s always good practice to disable all plugins first and then re-activate them one by one. Because most of the time, some plugin is to blame.

    Also, header errors can be caused by something as simple as a blank line above:





    Hi @ralph12

    I didn’t. As described above, it had all gone bazurk last night. I wanted to check what would happen if I replaced all the files in FTP with the ones from two days earlier (just an FTP backup), and the backup turned out crooked. Reversing what I just did gave the same result. Many files and folders appeared to be missing in all FTP backups. Beats me, completely flabbergasted. Still. Why, why would selecting all dragging to a harddisk result in copying only parts of it all. I never noticed this had gone wrong, so I was pretty much scre**d. Looking into it now, e.g. wp-content contains 5 folders. My backups contain only two. And I have no idea how on earth…

    So anyway. The webhosting guys went digging and trying. At first they didn’t seem to manage it either. But now they’ve placed a back-up from approx 2 days ago. Way before the error messages started to appear. So, no error messages, my life isn’t over, but I’ll have to re-do hours and hours of WP content stuff.

    Diagnostically, I can only tell you this: I tried to change something, through adding some code to the functions.php file in wp-includes. And I know I will never EVER try that again. Seems to me wp-includes prefers to be left alone :’)

    Cheers Ralph, and other viewers. Thanks for your concerns. Imma go check out which pages and parts exactly need fixing now. I’m afraid there’s a lot to be done. Shop settings, tens and tens of photos, and some pages’ content. But hey :) It’s up again!


    Hi @briefencv,

    Graag gedaan :) Pitty you have to re-do all the work, but good that the errors are gone now! Good luck with fixing the rest of it!




    Thanks Ralph. Dat zal wel lukken – uiteindelijk.

    For now, I’m what one could call oblivious. Just checked whether an as-usual drag-n-drop ftp copy move would work out like I’m used to. That’s how one makes an ftp backup, right? And to my surprise: 2099 succes & 425 fail. No wonder the backups were useless. So I first want to find out why this happens – I was like O.o

    Only then I’ll go and chain myself to finishing the website.



    @ralph12 – FTP settings for this particular server should have been set to SFTP. So now the backups are sound and complete. And 5 times larger than the backups I had made :’)


    Good to know!





    Glad you eventually got the website running again :)

    Best regards,

Viewing 18 posts - 1 through 18 (of 18 total)
  • You must be logged in to reply to this topic.