Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #966721

    Hi,

    I hadn’t updated since 4.2 and was trying to fix performance issues with child theme. then i saw 4.4 and the performance features and decided to update…
    but i keep getting 500 errors. i have tried :
    – increasing PHP memory
    – deactivating all plugins
    – deactivating child theme
    – testing on clean wordpress install (works fine)
    – clean wordpress install with 4.4 and child theme (works fine)
    – removing .htaccess
    everything seems to work pretty fine with clean install but when i import the hue database (around 40,000 products) i get the 500 server error.
    i’ve tested both on staging computer and running server.

    #967006

    Hey kavehmovahedi,

    Sorry for the problems. Did you try to completely remove the theme folder and then upload a fresh copy? Some files have moved between those two versions so that could be why you are getting the 500 error.

    Best regards,
    Rikard

    #967148

    Hi Rekard,

    yes i have. but had no luck… i think there must be something with the size of the database

    #967571

    i checked the log files, the problem is a sql timeout on wp_db, is there a database update going on?
    can i run that in command line?

    #967658

    Hi,

    Sorry for your problems, but I think your problems are related to core WordPress functionality. I’m not sure if we can be of much help to you. Maybe you could try posting your problem on a general WordPress forum instead? I think the chances of you getting help is greater if you do that.

    Best regards,
    Rikard

    #967749

    i think i found where the problem is.
    i turned on debug mode, saved all wpdb queries in a file and ran the website on local PC with xampp.
    here is what i found out :
    1) a script was timing out. -> i increase max_execution_time
    2) there were a lot of wp_db queries, updating database adding “_av_alb_posts_elements_state” meta keys to the posts
    this process takes about 20-30 minutes then i get and out of memory error…

    its definitely a problem with the database update and the size of my database… if you could give me a clue where is that code running maybe i could run it with python, or break it into smaller chunks to run it

    #969807

    finally got it working…
    i had to download the database to my development computer, run the update (had to setup my xampp, the database was too slow) then exported the database and uploaded it to the server.

    now everything works fine

    #969848

    Hi,

    Glad we could help!

    Please take a moment to review our theme and show your support https://themeforest.net/downloads
    Don’t forget to bookmark Enfold Documentation for future reference.

    Thank you for using Enfold :)

    Best regards,
    Basilis

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Huge databae, cant update to 4.4’ is closed to new replies.