Tagged: ,

Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #1219126

    I’ve been trying to switch my website from http to https off and on for a while now, and I just can’t get it to work. There is a valid and active certificate for the site, but the https version looks like parts of the site/theme are missing. I’ve tried several plugins to switch everything over to https, but they completely break it and have forced me to go to a backup copy. I have switched over serval sites in the past and never had this problem. You can see what I’m looking at by going to the website and changing http to https.

    Thanks for your help!

    • This topic was modified 3 years, 11 months ago by JD22333.
    #1219665

    Hey JD22333,

    Please send us a temporary WordPress admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #1223195

    Here you are.

    #1223351

    Hi,

    Thanks for that. Did you try to change your site URL and location to https on the page in private? That should be enough if you have a valid certificate already.

    Best regards,
    Rikard

    #1223401

    The problem isn’t switching to https i am able to do that fine. The problem is when I switch to https everything breaks.

    #1223410

    Hey,

    Could you please post FTP logins here privately as well? I have switched HTTP links to HTTPS but they still cannot be found.

    Regards,
    Yigit

    #1223417

    Here you are.

    #1223445

    Hi,

    Thanks! I am getting “Server said: Login authentication failed” error though. Could you please check the credentials once again?

    Best regards,
    Yigit

    #1223451

    Try this for the username.

    #1223647

    Hi,

    This works but this time path seems to be incorrect as only file I am seeing is .ftpquota

    Best regards,
    Yigit

    #1223736
    This reply has been marked as private.
    #1223754

    Hi JD22333,

    Yes, we have several theme members living there.

    Best regards,
    Victoria

    #1225666

    Any luck getting it to work?

    #1226439

    Hi JD22333,

    Credentials did not work for me. Could you please update the credentials?

    Best regards,
    Victoria

    #1229197

    Try this.

    #1229614

    Hi JD22333,

    Here are some links for you:
    http://www.wpbeginner.com/wp-tutorials/how-to-add-ssl-and-https-in-wordpress/

    https://www.thepolyglotdeveloper.com/2014/12/force-https-pages-wordpress-site/

    Please check the error when you get it and get back to us.

    Best regards,
    Victoria

    #1271233

    As I mentioned in my original comment, I tried real simple SSL before and it broke my site. Any other possible solutions? Are you thinking the manual method will work better?

    #1271234

    Also, when I try to just force https on the admin section, it says I have to login. Then when I try to go to my login page, it still tells me I have to login to see the page.

    #1272179

    Hi,

    Thank you for the inquiry.

    How did you install the SSL certificate? Did you use a tool to install the SSL certificate? The tool should automatically configure the httpd.conf file and create another config file for https or ssl after installing the certificate, but you could manually create it if it doesn’t exist. Do you have access to the httpd.conf file?

    Example of the SSL config.

    // https://httpd.apache.org/docs/2.4/ssl/ssl_howto.html

    Have you tried doing a search and replace to change all URL from http to https?

    // https://themify.me/blog/mass-replace-urls-https-wordpress-database

    Best regards,
    Ismael

    #1272188

    I just got on my site and half of it was deleted and all of the plugins are gone! Did you guys do this?

    #1272198

    Looks like someone from Kriesi was messing around with things. Gave me a minor heart attack. Please don’t start moving things around without switching them back when you are done.

    The SSL was installed through Cpanel, and I’ve tried the search and replace plugin along with the simple SSL originally, and it didn’t work. It was almost like WordPress wasn’t recognized through the HTTPS version.

    #1272616

    Hi,

    Sorry about that. We renamed the wp-content > plugins folder to completely disable the plugins, but we forgot to change it back. Before doing the search and replace, did you set the Settings > General > WordPress Address (URL) & Site Address (URL) from http to https?

    You should also configure the .htaccess file so that any http requests redirect to https. Please disable the cache and security plugins, then create a backup of the .htaccess file. After creating the backup, remove everything from the file, then replace it with the following.

    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301,NE]
    Header always set Content-Security-Policy "upgrade-insecure-requests;"
    
    # BEGIN WordPress
    # The directives (lines) between <code>BEGIN WordPress</code> and <code>END WordPress</code> are
    # dynamically generated, and should only be modified via WordPress filters.
    # Any changes to the directives between these markers will be overwritten.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    

    You can now do the search and replace afterwards.

    Best regards,
    Ismael

Viewing 22 posts - 1 through 22 (of 22 total)
  • You must be logged in to reply to this topic.