Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #28871


    I am using the Enfold Latest Portfolio widget on a page and found it’s quite useful.

    However, how to remove the creation date and time of each portfolio showed in the widget area? I only need the title to be shown.




    Try adding this CSS code:

    [id*="portfoliobox"] .news-time{ display: none }

    If it doesn’t work please post a link to your website so i can check it personally.




    Hi Josue,

    I added it to the Quick CSS field of ENFOLD settings section but it probably took out all the portfolios from the widget area so the outcome was none of the portfolios showed up. While I was trying to update and save the page, I got this error message,

    Fatal error: Call to undefined function layerslider_init() in /home/content/30/11045530/html/template/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow_layerslider.php on line 121

    Do you have any idea what might have caused this? The page I got this from is

    Then I tried a different page and now you can see the portfolio list at

    However, as you can see from the 2307 page, I got these messages,

    Nothing Found

    Sorry, the post you are looking for is not available. Maybe you want to perform a search?

    For best search results, mind the following suggestions:

    Always double check your spelling.

    Try similar keywords, for example: tablet instead of laptop.

    Try using more than one keyword.

    Feel like browsing some posts instead?

    On the page, I only have the ENFOLD Latest Portfolio widget there. Not sure where these messages came from.

    And BTW, the page directly changed to “” from “” and don’t know why is that.

    Sorry Josue, I asked a lot of questions here. Thanks again for your assistance.



    Hi yukanl,

    Try adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    .news-time {
    display: none;

    This will actually remove all of the time/dates from the recent post and portfolio widgets but if you can point to the sidebars with the widgets in place we can target only portfolio widgets with something more like:

    #portfoliobox-6 .news-time {
    display: none;

    Where the 6 is the instance of the portfoliobox widget. It just gets changed based on how many times you’ve added in that widget to your sidebars so that each has a unique ID.




    I’d like to remove the time from the “Latest News” widget. The following CSS code:

    .news-time { display: none; }

    works, but it also removes the date. Is there a way to remove just the time and keep the date?



    In your WordPress installaion please go to Enfold > Framework > Php and open Class-framework-widgets.php file and find following code in line 397

    $time_format = apply_filters( 'avia_widget_time', get_option('date_format')." - ".get_option('time_format'), 'avia_newsbox' );

    and change it to

    $time_format = apply_filters( 'avia_widget_time', get_option('date_format'), 'avia_newsbox' );




    Thanks for the quick reply Yigit. The code works great! :-)


    Hi Devin,

    Where can I find this portfoliobox id?



    I added this to the quick CSS field but it did not help.

    .news-time {

    display: none;


    I still see date and time displayed in the portfolio list.

    maybe I should try to find the portfoliobox id?



    @yukanl: If you’re using Chrome, right click on the portfolio box widget then click “Inspect Element”. Look for this line:

    <div id="portfoliobox-2" class="widget clearfix newsbox">

    You can use this to remove the date and time:

    #portfoliobox-2 .news-time {
    display: none !important;

    The widget id (#portfoliobox-2) might be different in yours. Please remove browser cache then reload the page a few times.




    Hi Ismael,

    I must be doing something not right. I followed your instructions and found out it is “portfoliobox-2”, added it to the quick CSS field but the date and time is still showing up in the area. Please check out the page,

    What did I do wrong?



    I didn’t see the css in either your Quick CSS or the custom.css file. Try adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    #portfoliobox-2 .news-time {
    display: none;

    That should work as I just test it on your site via dev tools.



    Sorry to keep coming back on this question. I added the css code to both Chinese and English version of the ENFOLD Quick CSS field but the date and time are still shown up on the page, I only referenced the portfolio widget once on the page and three courses are listed as below (sorry don’t know how to upload a screenshot so I just did a copy and paste directly from the page). As you can see, the time and date are still there.



    Test portfolio 3

    September 3, 2013 – 2:05 pm


    Test portfolio 2

    September 3, 2013 – 2:04 pm


    Test portfolio 1

    September 3, 2013 – 2:04 pm




    Please place the code on custom.css located on the css folder. Remove browser cache then reload the page a few times. If you have a cache plugin, flush the settings.




    I tested it and it worked. Thanks again for all the help and support the team provided to me. Appreciate it!

Viewing 15 posts - 1 through 15 (of 15 total)
  • The topic ‘How to remove creation date and time from the Enfold Latest Portfolio widget’ is closed to new replies.