Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
  • #22897


    For some reason after creating my homepage, when scrolling up and down the page, the site is somewhat glitchy and I’d like to smooth this out as much as possible. I also checked your theme demo and it’s pretty glitchy as well. Your demo is far more animated and feature rich than my site and mine still has this problem.

    What do you think is causing this and are there any known solutions?

    Thank you for your time.



    Can you be more specific about being glitchy? Can you point us to the areas where you see some issues?





    If you go to your theme demo and scroll down the homepage, you’ll notice that it’s not particularly smooth, the scrolling is very “blippy” or “choppy” if you will. Just to give you something to compare, if you go to and scroll down their page, you’ll notice that it’s not choppy at all and that scrolling down the page is very smooth.

    I was thinking the problem on my site was the speed of my hosting provider, so I checked your theme demo to see if it was choppy too and it is. In ruling out that this is a server issue, I’m now guessing it has something to do with all of the content that’s continuously loading (like the LayerSlider and Image Fade in Animation) while scrolling down the page. So…In the Advanced Layout Editor, I turned the Image Fade in Animation off on my site and it’s still choppy and I can’t figure out what the problem is?

    Basically, I’d like to have the site scroll as smooth as possible to give the user the best experience possible.

    Any ideas here to reduce this “blippy” or “choppy” behavior if not fix it completely?



    Personally I’ve no idea but I’ll tag this thread for Kriesi. Maybe he can provide some useful feedback or fix the issue. It will take some time though because he’s in Cyprus right now and will return on Friday.


    Thanks Dude and Ismael.


    Yeah, this is a really bad issue guys. I showed my CEO and CTO my proposed site today and both of them commented on how choppy it was. I was hoping a plugin like WP Super Cache or W3 Total Cache would buy me some time until Friday so that we could find a solution, but even the plugins didn’t help the issue.

    If Kriesi can figure out what’s wrong, I’d be ecstatic bc I love this theme! If he can’t though, this problem alone makes it to where I can’t use it for my company’s site.


    Looking at the demo I did not experience this “choppy” scrolling effect – no differencies to other sites. I’m using Windows 7 64 bit, Google Chrome and Firefox – maybe it has to do with 1.) your OS (MAC, Linux) or 2.) your browser?


    I’ve checked it in Chrome and Safari on three different Mac’s on three different network connections. Same thing in all circumstances.

    I can’t even tell you how bad I wish this wasn’t an issue bc everyone at my company uses a Mac and what I’m seeing on the Demo and my site looks really bad.

    You can check my beta site (I still have a lot of work to do) at

    Please let me know if you’re seeing what I’m seeing and if you have any suggestions to fix this.



    I tested your site on Mac in Safari and Chrome but didn’t really see any choppy scrolling. What I did notice when viewing the original enfold demo on smartphone was that it was indeed choppy. I’m guessing the homepage slider may be the cause of this.

    I’d suggest disabling the slider from the homepage and test it again. If the choppy scrolling is gone you could try adding a fresh slider (maybe it’s because of the multiple animations and images in the slider).

    Just my thought ofc.



    I did try to deactivate the slider on the homepage and the problem persists.

    If you scroll to the very bottom of the homepage, you should see the choppiness as you scroll. In the footer you’ll see the link to the privacy policy. This page is long and has no slider and the choppiness is present even on this page. Driving me crazy…

    Thanks for all the replies everyone!


    What are you testing on that is giving you the choppy behavior. I’m not getting it at all on my end with

    Chrome Version 26.0.1410.64 m

    Firefox 20.0.1 and 19

    IE9 64bit




    I am not getting it either. Macbook pro retina. also my custom built gaming pc.



    Well after seeing all of these posts, I just got on my HR Directors iMac and tried it in Safari and Chrome. For some reason it was smooth as could be and then I tried her assistants MacBook Pro and it was smooth too?

    Now I’m back on my MBP’s (I have a personal and a work MBP and all of these Mac’s are 2011 or 2012 models), and both have the issue but the iMac and assistants MBP dont’t?! I’m happy that it’s been narrowed down to my two laptops but so confused as to what the issue may be…

    I’ve tried both of my laptops on three different Wifi connections and no matter what my site is choppy?

    Thanks for the help guys.


    My guess based on that information is a specific add on you have running on both computers. Something that interacts with the browser and is effecting the rendering of the pages.

    Maybe a screenshot plugin or code inspection tool or even something like skype’s phone number tool that scans pages for phone numbers and makes them clickable (even a program/app that does something similar).




    Just wanted to say Kudos Devin, that’s exactly what the issue was. I have LastPass installed on both laptops in Chrome and Safari, and as soon as I disable the extension, the page scrolls smooth exactly as it should…

    Very happy to be given the suggestions needed to find the solution here. I really appreciate everyone’s help.



    Glad we could help :)

    Let us know if you have any other questions or issues.



Viewing 16 posts - 1 through 16 (of 16 total)

The topic ‘How to make glitchy scrolling smoother’ is closed to new replies.