Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #862173

    Hi, there–
    Is there a way to NOT show a post in Related Content when actually on that particular page? Please see Private Content for the link to a page in question. At the bottom of the Post is the section “Related Posts” and beside it “Post from..” which draws in the author titles. As it is now the post title and link that are shown include the page one is already viewing. That seems unnecessary. Is there a way to exclude the page it is on?


    Hey GWS,

    Go to Enfold > Blog Layout > Related Entries (set this to) Disable Related Entries. Hope this helps. :)

    Best regards,


    Sorry, I don’t think I explained our issue very well. The instructions you provided are for turning off Related Entries everywhere. We don’t want to turn off Related Entries at all–in fact, we are using that feature a lot. What we want to avoid is the related entry listing the post when the viewer is actually viewing that post. For instance, in the private content I provided the page with the title “What Parents Need to Know…” We’d like it to show related entries in the Post Slider widget but right now one of those entries is the same post “What Parents Need to Know…” that is already being viewed. This is also occurring with the Magazine widget where we are trying to display Other Posts by the Author. We don’t want the same post to show up there. Is there a function that can be added which would exclude the post you are viewing from displaying in these two widgets?


    Hi GWS,

    Here a thread for you to consider:

    It also looks like you don’t have any other posts, so this could be why it is showing up.

    Best regards,

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.