Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #773147

    I am using Foogallery to showcase a particular media gallery. When those images are clicked, they automatically open in the magnific popup, which is actually good. The problem happens when I have to link those images to a custom link or a video – then the magnific popup overrides the custom URL that I set in FooGallery, rendering all the effort useless. I am wondering if there is any way to select an element using an ID or Class (using CSS or jQuery) and disable the magnific popup only for custom links on those elements so that FooGallery’s default functionality can work.

    PS – I am using a child theme.


    Hello architchandra,

    that is easy. You don’t need to use CSS or jQuery. Go to galleries, edit the gallery you want to work customs links and simply change in the middle of Gallery Settings [ Links -> from Full Size Image to Custom URL]. See the link

    After that changes, don’t forget to put update button. Refresh the page with gallery and now it’s work,

    Thank you. I hope this may help you.


    Of course I tried that before posting here. But it didn’t work. Magnific popup was overriding the FooGallery settings.



    Can you please contact the plugin developer to help you out?
    It is way easier for them to locate the problem and help you.

    Thanks a lot



    Hello architchandra,

    i has the last version of WordPress and Enfold theme. That plugin work perfectly.

    Maybe you need to do update the WordPress and Enfold theme to last version. Also, deactivate all plugins to see if that works.

    Finally, if all of them doesn’t work, contact the plugin developer to help you out.

    Thank you. I hope this may help you.


    @architchandra I dont know your plugin put if possible apply the css class ‘noLightbox’ to it and enfold will ignore that link/image

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.