Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #388488

    Hi,

    how can I disable the JPG compression for the gallery element in the Layout Builder?
    I have this in my functions.php:

    add_filter( 'jpeg_quality', create_function( '', 'return 100;' ) );

    but this takes only effect on normal images, that I add to a post. But when I add images to the gallery, where I set “NO SCALING”, then the images are blurry.

    Settings:

    Blurry image in the gallery:

    Normal image in the same page/post:

    How can I disable the JPG compression for the gallery element and its images or – much better: do you have another advice for me for sharper images in the Gallery element?
    Thanks.

    #388499

    UPDATE:

    I found out with Firebug, that it’s not a matter of JPG compression, but the Gallery element downsizes my image to 650 px instead of the original image width of 670 px – and this ALTHOUGH I have made the settings to “NO SCALING ( ORIGINAL WIDTH & HEIGHT). Maybe this is because of the border that appears around the gallery image?

    How could that be??

    #389135

    Hey colorit2!

    It’s most likely the border/padding around the image which scales it down a bit, would you like to remove it? If so, please reply to this thread and we’ll provide you with the necessary code.

    Regards,
    Rikard

    #389146

    Hi!

    Thank you for using Enfold and for explaining the issue thoroughly.

    The big preview on the gallery will always inherit the width of its container, the size of the columns, main container etc, so there’s no easy solution to this problem especially when you’re using gallery images with different sizes. Try to use larger images then disable the Force same size for all big preview images? gallery settings.

    Best regards,
    Ismael

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.