Tagged: ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #1355257

    Hey Gunter,

    Discovered something a while back I forgot to mention.

    In enfold theme settings, when you choose a page as the homepage, the domain plus the page slug become the canonical url for the homepage. eg:


    This isn’t ideal for a few reasons, and also isn’t how WordPress works if you ignore the Enfold theme settings and rather select a homepage using the settings found in Settings > Reading. If you use this instead, it correctly ignores the page slug and the canonical for the homepage is simply the domain url.

    See below for examples.

    Is this something you could improve for the theme settings?

    Thanks as always,



    Hey Tim,

    Thank you for the inquiry.

    We cannot reproduce the same issue on our installation. The slug of the home page is automatically removed from the canonical URL. You might be using a plugin or a custom script that alters this URL.

    Are you using the Yoast SEO plugin? You can manually change the canonical URL in the Yoast SEO > Advanced panel. There is a canonical URL field in this tab. Please check the article below.

    // https://yoast.com/rel-canonical/#setting

    Best regards,


    Hey Ismael,

    Wow, think this is Yoast’s problem, and not yours as you say.

    Would have thought Yoast was smart enough to automatically take care of that (like RankMath does) but seems not.

    Thanks, can close this one up.




    Glad Ismael could help, if you have any further questions please create a new thread and we will gladly try to help you. Thank you for using Enfold.

    Best regards,

Viewing 4 posts - 1 through 4 (of 4 total)
  • The topic ‘Home page canonical’ is closed to new replies.