Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1073078

    Hello,

    I want to show a submenu on some sites only on mobiles devices / small displays. When I work with the display:none; css, there still appear some placeholders and white spaces.

    Do you have an idea how to hide this submenu, so that on the desktop version it leaves no trace?

    Thanks a lot!

    #1073089

    Hi,

    Please go to Enfold theme options > Main Menu and choose alternate menu for mobile with submenus in “Alternate Menu for Mobile”. You would simply need to create additional menu without submenus and choose it as your main menu then choose the one with submenus as your mobile menu :)

    Best regards,
    Yigit

    #1073117

    Hello Yigit,

    Thanks a lot.
    I think I didn’t explain myself properly. Sorry. I want the main menu always stay the same. On some pages I would like to have a additional submenu on the page, which is only displayed on small displays and mobile phones. I worked with the full-width submenu element in the advanced layout builder and tried to hide it via css, but than there remains empty spaces in the desktop version. Also, I have a full-width submenu element on the start-page that I want to display always.

    Hope there is a possibility for that.

    Thank you!

    • This reply was modified 6 months, 2 weeks ago by  digitalbehh.
    #1073411

    Hi,

    Thanks for elaborating!

    Please go to Enfold theme options > Layout Builder and check “Show element options for developers”. Then edit Submenu elements you would like to hide on desktop and give them “desktop-hidden-submenu” custom CSS class and then add following code to Quick CSS

    @media only screen and (min-width: 1024px) { 
    .desktop-hidden-submenu { display: none !important; }}

    I tried this on my local installation and it worked and did not leave whitespace. If it does not work for you, please post temporary admin logins privately and point out the submenu elements that you would like to hide on desktop :)

    Best regards,
    Yigit

    #1075013

    Hello Yigit,

    thanks! Yes it worked. I didn’t know the “Show element options for developers” feature. That helps a lot!

    Thank you!

    #1075075

    Hi,

    Glad we could help! :)

    For your information, you can take a look at Enfold documentation here – https://kriesi.at/documentation/enfold/
    If you have any other questions or issues, feel free to start a new thread under Enfold sub forum and we will gladly try to help you :)

    Best regards,
    Yigit

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Hide Submenu on desktop’ is closed to new replies.