Viewing 25 posts - 1 through 25 (of 25 total)
  • Author
    Posts
  • #920816

    Is there a way to hide the two (sometimes one) spinning wheels when the background video is loading from the fullscreen slider? or at least just show one?

    I’m showing a video hosted on my server, not from youtube or vimeo

    #921024

    Hey kilimats,

    The theme does not show 2 loading spinners it may be due to a plugin conflict or custom code.

    Please try adding this code to the Quick CSS section under Enfold > General Styling or to your child theme’s style.css file:

    
    #top .avia-fullscreen-slider .avia_loading_icon {
        display:none;
    }
    

    Best regards,
    Vinay

    #921026

    i’ve added the code but still as pictured in private.

    related question: Is it better/faster to load the video form youtube or local in your opinion? how would you optimize them properly for faster locading if local? do you recommend an rendering configuration?

    • This reply was modified 5 years, 11 months ago by yingyang.
    #921054

    Hi,

    I personally would use YouTube simply because any file that you add to your site locally will add to page weight which in turn affect page ranking. YouTube, on the other hand, optimize the video very well to load fast and there are some advanced embed options which let’s you customize the video.

    https://developers.google.com/youtube/player_parameters

    https://youtubeembedcode.com/en/

    If you still have an issue please share the admin login details so we can take a closer look :)

    Best regards,
    Vinay

    #921079

    Thabks Vinay, i agree with you that it will speed up the page loading time, though one issue i noticed in the past with background youtube videos in enfold is that if the connection is slow, a lower quality is used making the video extremely pixelated, is there a way to force a high resolution with enfold?

    Edit: Missed the link yiu gave to custom embed, ill try generating a custom link to use in the slider to see if the resolution is kept high thanks!

    • This reply was modified 5 years, 11 months ago by yingyang.
    #921103

    That is precisely why I moved to self-hosted video… I ran into the same problem. Youtube prioritizes page load over quality, so I found even on a 250 mbps connection, the first few seconds were pixelated while the video played and loaded simultaneously. The only way I could get around it was to self-host the video, which does eat up bandwidth. Now I am using a hybrid of that, self-hosting a small 12 MB video compressed with Handbrake, and an option to play the Youtube video in a lightbox…. this however requires a slider plugin. I’m using Smart Slider, not sure if you can do it with Layerslider. You can see an example here: http://www.thomashenthorne.com/65-los-ranchitos-road/

    Cheers,
    Rob

    #921191

    Hi,

    To force youtube video to play in HD or any specific resolution you can try any YouTube embed generator. Once the embed code is generated just copy the URL in src=””.

    <iframe frameborder="0" scrolling="no" marginheight="0" marginwidth="0"width="788.54" height="443" type="text/html" src="https://www.youtube.com/embed/KzBdWJJsIHY?autoplay=0&fs=0&iv_load_policy=3&showinfo=0&rel=0&cc_load_policy=0&start=0&end=0&vq=hd720&origin=https://youtubeembedcode.com"><div><small><a href="https://youtubeembedcode.com/en">youtube embed code</a></small></div><div><small><a href="https://promocode.com.ph/lazada/">Going Here</a></small></div><div><small><a href="https://youtubeembedcode.com/en">youtube embed code</a></small></div><div><small><a href="https://www.bol.com/nl/p/hoogwaardige-sokaantrekker-hulp-sok-aantrekhulp-deluxe/9200000086907422/">bol sok</a></small></div></iframe>

    Again this depends on the video setting while uploading if it supports this resolution and other factors.

    https://www.youtube.com/embed/KzBdWJJsIHY?autoplay=0&fs=0&iv_load_policy=3&showinfo=0&rel=0&cc_load_policy=0&start=0&end=0&vq=hd720

    Or simply add &vq=hd720 to the end of your youtube URL

    Best regards,
    Vinay

    #921248

    Thx Vinay, tried generating your code but when used in the full screen slider it just show a spinning wheel forever, never loads

    Can you help me generate a code to force 1080p on the private urls?

    #921394

    Hi,

    After researching some more on this issues I found out that Google has deprecated some features that allowed to force playback videos in HD. The URL format still works but simply plays the video in default quality/settings.

    The URL format is not supported in the slider. Maybe you can give some advance embed plugin a try.

    Best regards,
    Vinay

    • This reply was modified 5 years, 11 months ago by Vinay.
    #921441

    THanks Vinay,

    So ill keep using the build in fullscreen slider for now, i jsut want the video to load with the double spinning wheels, very distracting and unprofessional, i’ve added the CSS above but no luck, anything else can work ?

    #921554

    Hi,

    Yes, the 2 loading spinner is distracting. It does not work like that unless some custom code or plugin is in conflict. Please provide us admin login details in private so we can take a closer look at it.

    Did you de-activate all plugins and check if the issue still persist?

    Best regards,
    Vinay

    #924319

    THanks Vinay, i did disable all plugin beside woocommerce but no luck (disabling woocommerce makes my site crash for some odd reason). I’ve added the login details below. Also i had to enable THEME MY LOGIN after testing because the login form doesnt work otherwise, feel free to disable it for your testing though

    #924377

    Hi,

    I tested your page shortcode on my local installation and the slider had only one loader.

    However, the below code is added to remove the default loader from the theme.

    #top .av-video-slide .avia-slide-wrap{ background: #000 url("")!important; } 

    Our theme uses ../images/layout/preload-dark-grey-big.gif the one you see right now appears to be a CSS preloader.

    Also noticed the big loader appears only when using the self-hosted video. The big loader that you see right now is not from the theme. It appears you have a lot of deactivated plugins and it’s possible the loader may be a left out trace from one of the plugins.

    Best regards,
    Vinay

    #924401

    Super investigation Vinay, thank you very much ! is there a way to find out where the top spinner comes from? because using youtube video isnt an option since there is no way to force 1080p, appreciate all the help very much !

    #925190

    Another issue i’m seeing is the video being shrink-ed to the top bar as pictured privately, it fix itself as soon as you maximize the browser window. any idea why it does that?

    #925262

    Hi,

    That is an issue that has been appeared on our latest version.
    But, I just loaded the web site and I can see it working properly, so I suppose the issue is been fixed?

    Best regards,
    Basilis

    #925282

    That shrinking video issue is random, after i posted it here it started working fine again without any changes, weird!

    #925574

    Hi,

    I’m sorry I cannot find where the loading image is coming from. I will check with the rest of the team and let you know.

    Best regards,
    Vinay

    #925610

    Hi kilimats,

    If the issue appears again, try the solution posted in this thread: https://kriesi.at/support/topic/fullwidth-easy-slider-video-not-working-after-update/#post-919498
    This should be fixed in the next release of Enfold :)

    Cheers!
    Nikko

    #931373

    Thx Nikko added ! looking forward to new version!

    Hi Vinay, anything i can help out with to narrow down where this spinning wheel is coming from? ive disabled all plugin already but no luck? is there a file i could overwrite with the original enfold version maybe?

    #931525

    Hi,

    For testing purpose could you please delete the loading gif from wp-content/themes/enfold/images/layout/preload-dark-grey-big.gif via FTP or File Manager on your hosting control panel.

    Let us know if this works.

    Best regards,
    Vinay

    #932288

    I removed it but still showing on my end

    #932815

    Hi,

    I can’t see the spinning wheel or preloader icon anymore. Please try this css code to hide the preloader icon completely.

    .mejs-overlay-loading-bg-img {
        display: none !important;
    }

    Best regards,
    Ismael

    #1205164

    @Ismael,

    Your code worked!

    Thank you dear.

    #1205382

    Hi Oref,

    Great, I’m glad that you got things working.

    Best regards,
    Rikard

Viewing 25 posts - 1 through 25 (of 25 total)
  • You must be logged in to reply to this topic.