Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
    Posts
  • #743077
    #743332

    UPDATE: I tried a fix I read about on this forum having to do with the W3 total Cache plugin – renamed it via FTP but then if I logon to the site, I get an error about files missing and would I like to delete them. I didn’t go any further. SInce I am also getting an error on Manage WP (see above) I am unable to just deactivate the plugin. ANY IDEAS???

    thanks again,
    Nancy

    • This reply was modified 3 years, 7 months ago by  Munford.
    #743865

    Hey!

    Thank you for using Enfold.

    I tried to login to the site but the credentials above are not working. Please check it carefully. Is there any reason why you can’t deactivate the plugin temporarily?

    Best regards,
    Ismael

    #743912

    I tried to deactivate it by changing the name of the plugin via ftp but that didnt’ work. Is there another way to disable plugins if you can’t get into the admin?

    Now I have reverted to a previous backup before I updated to WP4.7 and that worked.
    I disabled the W3 Total Cache before updating WP to 4.7 and the same thing happened again – blank.
    I have now reverted again, and maybe you could take a look?
    Are there other issues with WP 4.7 + enfold that could be causing this?
    The site is backed up now if it needs to be tested again.

    thanks again.
    Nancy

    • This reply was modified 3 years, 7 months ago by  Munford.
    #744577

    Hey!

    Thank you for the update. I was able to login but I can’t do anything because the account has no “admin” rights. Please set the user role to admin.

    Best regards,
    Ismael

    #744745

    sorry = you’re an admin now

    I think the problem may be with WPML and WP 4.7, since I have other sites running 4.7 without issue and this one is the only one running wpml….which I need!

    Let me know if you find something else.
    I also noticed you deactivated wordfence – was that for testing?
    thanks
    Nancy

    #745249

    Hey!

    Thank you for the update.

    I also noticed you deactivated wordfence – was that for testing?

    I wasn’t able to do anything yesterday because the account is not an administrator. Where can I see the issue again? I don’t see any errors in the dashboard.

    Best regards,
    Ismael

    #747933

    If you update to wordpress 4.7 you will see the problem.
    I reverted back to 4.61 so I could update the site, and won’t move to 4.7 before I know this problem is fixed.
    I have a backup if you want to test it.

    #748259

    Hey!

    Please update to the latest version so that we can see the issue. We’ve checked a lot of sites in version 4.7 and they don’t have this issue so it’s probably cause by a plugin or a custom modification in the site.

    Cheers!
    Ismael

    #749256

    OK I have updated to 4.7 and now the admin is blank again.
    think maybe it’s a problem with WPML
    Can you check it now?
    thanks very much
    Nancy

    • This reply was modified 3 years, 7 months ago by  Munford.
    #749712

    Hi!

    In the wp-config.php file, did you set the WP_DEBUG constant to false? Please post the FTP details here so that we can check it thoroughly. Do you have the latest version of the W P M L plugin?

    Regards,
    Ismael

    #749872

    I have to find my ftp password for you since I can’t see it on filezilla and I can’t find my record for it.
    I can access the site via FTP and the wp-config is set to false. Should I change that to true?
    Please leave this thread open and I will get back to you.

    • This reply was modified 3 years, 7 months ago by  Munford.
    #750267

    Hey!

    Yes, please set the WP_DEBUG to true and add this constant below.

    define('WP_DEBUG_DISPLAY', true);
    

    Cheers!
    Ismael

    #750460

    OK I did that –
    still getting a blank page admin.

    found the ftp login below if you need it.

    I tried at one point renaming the WP total cache plugin via ftp to disable it but that gave a different error message and did not solve the issue.

    thanks
    Nancy

    #751204

    Hi!

    We modified the wp-settings.php file, renamed the wp-content > advanced-cache.php, db.php file and wp-content > cache directory and then disable the plugins directory. You can now login to the site but the plugins are deactivated. We are sure that the wp cache plugin is one of the issue but there might be another plugin that is causing the error. For a simple test, enable the plugins directory via ftp then rename each plugin one at a time and check the wp-admin on each attempt.

    Cheers!
    Ismael

    #751347

    Hi Ismael

    OK so I did all that and did not reactivate the total cache plugin and it seems to be fine….after I lost some content in one of my widgets (?)
    One problem – my news page is not displaying correctly now. I have checked the settings and can’t find the problem. I am using the blog element and not selecting a blog page on the theme options.
    The english news page is now displaying with no sidebar, for some reason, even though its set for a right sidebar, and seems to be pulling the news category instead of the page if you click on the language switcher. If you go to “NYHEDER” on the danish page, it’s OK but the language switcher seems to go to the NEWS category instead of the page. Have not seen this happen before.
    can you help me with this?
    thanks
    Nancy

    • This reply was modified 3 years, 7 months ago by  Munford.
    #752134

    Hey!

    after I lost some content in one of my widgets (?)

    I’m not sure why it’s lost but I’m sure it’s not that difficult to put it back since it’s just a widget.

    One problem – my news page is not displaying correctly now. I have checked the settings and can’t find the problem. I am using the blog element and not selecting a blog page on the theme options.

    Did you set the Blog Layout > Blog Layout to “Use the advance layout builder..”?

    The english news page is now displaying with no sidebar,

    Do you have a category called “news”? Please change its slug to something else.

    Cheers!
    Ismael

    #752231

    thanks got it working.
    One issue – my blog posts were no longer ordered by recent date, but were seemingly random.
    I have a re-order plugin, and I have now fixed it by hand, but would like to understand why the blog was at all affected by the recent update.
    I have not had problems with it before, as they were ordered by descending date. Is there a setting for this?

    Also – when you said “We modified the wp-settings.php file” can I ask what the modification was? Was it only an issue with the Cache plugin?
    Thanks so much for your help.
    Nancy

    • This reply was modified 3 years, 7 months ago by  Munford.
    #752747

    Hey!

    Also – when you said “We modified the wp-settings.php file” can I ask what the modification was? Was it only an issue with the Cache plugin?

    We commented out or remove a W3 Total Cache configuration in that file.

    One issue – my blog posts were no longer ordered by recent date, but were seemingly random.

    Do you have any query filter in the functions.php file?

    Cheers!
    Ismael

    #752936

    no I don’t think I have a filter in the functions.php

    #753437

    Hi!

    It has to be a filter or the error is caused by a plugin. The blog post query is set to the default settings. Please try the “avia_blog_post_query” filter. Example:

    add_filter('avia_blog_post_query', 'avia_blog_post_query_mod');
    function avia_blog_post_query_mod( $query ) {
    	$query['orderby'] = 'date';
    	$query['order'] = 'DESC';
    	return $query;
    }

    Adjust the values as needed and add a conditional function in case you need one.

    Cheers!
    Ismael

    #760626

    resolved thanks

    #761159

    Hi,

    Thanks for the feedback. Please open a new thread if you should have any further questions or problems.

    Best regards,
    Rikard

Viewing 23 posts - 1 through 23 (of 23 total)

The topic ‘HELP – blank admin page after login’ is closed to new replies.