Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1101478

    Hello there,
    big issue here: running WP 5.2 and Enfold 4.5.7
    Everything’s great in backend – but on frontend theres only “access denied”
    Tried to turn on debug mode – no more information were displayed…

    Please check login credentials in private content.

    Best regards,
    KEL

    #1101526

    Hey KELmedia,

    I checked the frontend pages but I could not find “access denied”, can you give us a link or steps how we can see this? or is it already fixed?

    Best regards,
    Nikko

    #1101549

    Hi Nikko,

    I called the webhoster as I found something like “rest API error 403” – the hoster told me, that the malware scan detected an infected file – which was index.php in root folder. That’s why they shut down the whole site …. but here come’s the strange thing: index.php is totally ok.

    They made the side accessible again but told me, that if a further scan detects something strange they’ll shut it down again.

    So I really don’t know, what the problem could be. I did a scan through the whole installation and found NOTHING…. The error occured after updating WP and Enfold to newest versions….

    Kind regards,
    KEL

    #1101617

    Hi KEL,

    Glad that it’s fixed though I’m sure that Enfold doesn’t contain any malware.
    index.php in the root folder should be the WordPress index.php file which is only 1kb and you can easily check without looking through a lot of code and you can compare it with the one in the WP repository.
    I think if that happens next time you can try to enable WordPress Debugging to figure out what’s causing it. Here’s a link: https://codex.wordpress.org/Debugging_in_WordPress :)

    Best regards,
    Nikko

    #1101682

    Hi Nikko,

    I’m also sure about no malware in Enfold :)

    Websites can be hacked, that’s a fact, but I couldn’t find any corrupted code in WP …
    Debugging did not work as the webshoster made the website unaccessible. Only way to make frontend accessible was to call the host and tell him to do so. We will see whether it was a problem with the webhoster or with WP itself. I checked the whole installation by searching for the strings they told me would cause the problem but couldn’t find them in any of the files.

    Thanks again – you can mark this thread as solved.
    My best regards to you and your team!
    KEL

    #1101690

    Hello Nikko,

    it’s me again …. found a corrupted line in
    wp-content\themes\enfold\includes\admin\dummy.xml:14562: <wp:comment_author_email> (Email address hidden if logged out) </wp:comment_author_email>
    I’d like to delete this file – question: if I do so, will the website still work correctly?

    Thanks a lot in advance
    KEL

    #1102194

    Hi KEL,

    Yes, you can delete this file. The website will still look fine.

    Best regards,
    Victoria

    #1102265

    Hi Victoria,
    thanks – file is deleted, website still looks very good :)
    Have a wonderful sunday and thank you for your help.

    Best regards,
    KEL

    #1102385

    Hi KEL,

    Thanks for the update. Please let us know if you should need any further help on the topic or if we can close it.

    Best regards,
    Rikard

    #1102402

    Hello Rikard,
    thanks again for Victoria’s and your help – you do a great job here :)

    Of course, you can close this topic.

    My best regards to you and your team,
    KEL

    #1102605

    Hi,

    I’m glad this was resolved. If you need additional help, please let us know here in the forums.

    Best regards,
    Jordan Shannon

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘HELP!!! Backend works – Frontend "Access denied"’ is closed to new replies.