Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #730450

    I have updated the theme to the most recent version and am having a weird problem. Actually the problem started before I updated the theme and I was hoping this would fix the problem. Also we are using WP 4.7 so not sure if this is a result of that? Siteground did the auto update and I am not sure exactly when that 4.7 update happened.

    Problem: The header with the logo and menu plus the top nav is no longer sticky. I don’t know why. And the green/blue background is constantly showing above the header and the header stays put while you scroll and text images etc display above it.

    Here’s what I have done so far:

    1. Disabled every non Enfold related plugin. This includes autoptimize, sgcach,the security plugin, smushit, everything but the necessary plugins.
    2. looked at the header section on the theme options – have confirmed that both sticky header and shrinking header are checked.

    Any idea what is going on?

    Thanks Yvonne


    Hey ycoleman31,

    I checked the setting and it appears to be fine. When I scroll the homepage the header sticks to the top please check the screenshot below. You may not see the changes until the cached files are cleared in your browser.

    Please try to hard refresh by pressing Ctrl + Shift + F5 on your browser or press the F12 key to open chrome dev tools and right click on the refresh button and select “Empty Cache and Hard Reload” and review the site again.

    If you still have any issue please let us know which device and browser you are facing this issue and if possible upload a screenshot/mockup to and share the link here so we can help you better :)

    Best regards,

    • This reply was modified 4 years ago by  Vinay.

    Hi Vinjay,

    I’ve done all of the above to no avail. I have check with the company’s office in Phoenix (we are in Orlando) and they are seeing the same problem.

    Has anyone else had a similar issue?




    your header seems to be sticky for me:

    However, I guess this is related to your caching plugin. Switch off any caching inside your caching plugin’s settings. Then deactivate your caching plugin. Clear browser cache + hard refresh a few times. Check on another computer as well.

    Which browser and OS are you using? make sure to use newest browser version always.

    Best regards,


    Hi Andy,
    Looking at your image, you were definitely seeing what i was seeing. I have attached a screen shot of what you uploaded to

    That being said, i have resolved the issue by tweaking the settings on autooptimize plugin. You were on the right track with the caching plugin conflict.

    Selecting this: “Check this option for Autoptimize to also aggregate JS in the HTML. If this option is not enabled, you might have to “force JavaScript in head”.

    Thanks for your help!



    glad we could help! So is this issue fixed for you now? let us know so we can close this thread or keep it open for you if you still need help on it.

    Best regards,


    Hi Andy,
    The issue is resolved.

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Header is not sticky’ is closed to new replies.