Viewing 25 posts - 1 through 25 (of 25 total)
  • Author
    Posts
  • #724362

    Dear support team,

    on our page https://www.hapkido.academy i experience problems, when switching to a page (with anchor).
    When the page is not loaded yet, the top of the section is hidden by the header; loading the same page (with same anchor) again corrects the problem.

    Browser: Firefox, Internet Explorer on Win 10
    You should be able to reproduce this behaviour by clicking Hapkido/Geschichte from the Main page (or any other anchor based link).

    Is this a bug in your theme?
    Am i doing something wrong?

    I attached links of a sample output in case you can’t reproduce the effect instantly.

    Please let me know, if you need login credentials!

    best regards,
    Tom

    #725494

    Hey Thomas,

    Please give us temporary admin account, also can you post the link of the page where you have the screenshot, I checked the link given above but I see the cool video instead of the two columns :)

    Best regards,
    Nikko

    #725507

    Hi Nikko,

    You should be able to reproduce this behaviour this way:
    1) click Hapkido/Geschichte from the Main Menu
    2) click Training from the Main Menu (alignment incorrect)
    3) click Hapkido/Geschichte (alignment incorrect)
    4) click Hapkido/Geschichte again (alignment OK!)

    I provide some credentials for you below.

    best regards,
    Tom

    #725525

    I nearly forgot (see private content) !

    #727081

    Hi,

    Please deactivate all plugins one by one to check which one is causing this issue and let us know if this solves the problem.
    In addition to that, please let us know if we are allowed to deactivate one or more of your plugins as well for testing purposes :)

    Best regards,
    Andy

    #727085

    Hi Andy,

    i just checked (again): same behaviour with all plugins deactivated.
    And yes, feel free to (temporary) deactivate plugins for testing.

    best regards,
    Tom

    #728030

    Hi,

    I followed these instructions:

    1) click Hapkido/Geschichte from the Main Menu
    2) click Training from the Main Menu (alignment incorrect)
    3) click Hapkido/Geschichte (alignment incorrect)
    4) click Hapkido/Geschichte again (alignment OK!)

    But now the issue doesn’t happen for me anymore. Could you fix it already?

    Best regards,
    Andy

    #728078

    Hi,

    no, i didn’t fix anything.
    But i found an even easier way to reproduce the issue:
    (it happens on Internet Explorer 11 (11.0.9600.18537) on Win7 (64bit) as well as on Firefox 50.1.0 (64bit) on Win7 (and Win10))

    1) just call https://www.hapkido.academy/#training directly – you should see the problem immediately. Clicking then “Training” from the main menu corrects the wrong alignment.

    best regards,
    Tom

    #728124

    Hi,

    There might be some corrupted files, so please delete all theme files completely via FTP, before installing a fresh copy from your themeforest account. Here is a short tutorial on how to install the theme via FTP, in case you are not sure how that works:

    Best regards,
    Andy

    #728474

    Hi,

    i reinstalled all theme files via FTP from themeforest, but this didn’t change anything.

    best regards,
    Tom

    #728500

    Hi,

    some custom code you’re using might cause this issue. Please remove any custom code to check which one is causing it and let us know about your results here.

    Best regards,
    Andy

    #728520

    Hi,

    i temporary disabled the custom code (you inserted due to this issue: https://kriesi.at/support/topic/responsive-adjust-to-content-width-in-portfolio-raster-doesnt-work/#post-710086 ) , but the problem still exists.

    However, there is some custom Quick CSS stuff (not written by myself). Could you have a look, if there is some possible interference with your theme anchor handling?

    best regards,
    Tom

    #728548

    Hi,

    remove any custom code (inside your Quick CSS field), to check if one is causing this issue and let us know about your results here.

    Best regards,
    Andy

    #728554

    Hi,

    still same (wrong) behaviour (without any Quick CSS code).

    best regards,
    Tom

    #728563

    Hi,

    deactivate your child theme and activate default Enfold theme instead. So remove ANY customizations you’ve done so far. I’m pretty sure some customizations are causing this issue. I hope you find out which ones are causing it this way.

    Best regards,
    Andy

    #728575

    Hi,

    i did as you asked – same output! (though it’s not so obvious, due to the narrower header)
    I’m afraid there _is_ a problem in your theme.

    best regards,
    Tom

    #728581

    Hi,

    are we allowed to remove any of your customizations and to activate default Enfold theme? to check it?

    Best regards,
    Andy

    #728585

    Hi,

    yes, but please bring it back to the actual state afterwards!

    best regards,
    Tom

    #728591

    Hi,

    when I activate default Enfold theme then it’s working fine: http://imgur.com/a/vHcOg

    Best regards,
    Andy

    #728597

    Hi,

    as i told you, it’s not so obvious: click on “Training” and you will see, that it’s scrolling down to the real anchor top!

    best regards,
    Tom

    #728620

    Hi,

    I’ll report this issue to Kriesi. Hopefully he can fix it soon!

    Best regards,
    Andy

    #741256

    Hi,

    any news regarding this issue?
    When do you estimate a fix?

    best regards,
    Tom

    #742501

    Hi,

    I’m afraid Krieis is very busy with lots of other issues and improvements. So in the meantime you can take advantage of this plugin: https://wordpress.org/plugins/hash-link-scroll-offset/

    Hope this helps you!

    Best regards,
    Andy

    #742548

    Hi and thanks,

    this workaround definitely helps!
    Anyway, please let me know as soon as there’s a real fix, so that i can deactivate the workaround plugin …

    best regards,
    Tom

    #742585

    Hi,

    Glad it’s working for you :)

    This usually happens when the header is modified or a custom code is used. Do not worry the plugin does not in any way affect the site performance. You can always remove the customization to the theme and it should work just fine.

    Best regards,
    Vinay

Viewing 25 posts - 1 through 25 (of 25 total)

You must be logged in to reply to this topic.