Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #1245033


    After debugging for 2½ hours I throw in the towel and ask for help regarding my website’s contact page:

    The message “This page can’t load Google Maps correctly” and the watermark “For development purposes only” keeps showing.

    In the Enfold Settings the API Key is validated correctly. The API Library is activated as it should. The Application Restrictions are set as they should with wild cards and direct urls. All caches has also been cleared multiple times.

    None of the above have fixed the issue. I am hoping for your help.
    The login credentials has been posted in the following post.

    Thanks in advance.

    This reply has been marked as private.


    Thanks for that, the login details are working, but I’m getting a server error once the backend should start loading, please see private.

    Best regards,


    I’m experiencing the same problem
    Please help


    I have tried logging into the account myself and I also got the server error the first time.

    Try logging in again, then it should be working.


    Hi mp3dk,

    Thanks for the update, the login details are working now. I see that you have added what looks to be a valid API key, but you are still getting this error message from Google Maps: It doesn’t make much sense if the key is valid, could you check that the key was pasted correctly first of all please? If that is not the problem then please try deactivating your caching plugins to see if that makes any difference.

    Best regards,


    Hi gitte_lund,

    Please open a new thread and include WordPress admin login details in private so that we can have a closer look at your site.

    Best regards,



    I have tried purging everything relating to caching and also tried deactivating the cache plugins. Neither helped on the issue.

    Also, I tried re-validated the API key. The key was validated, but it didn’t help on the issue.

    What’s next?


    Hi mp3dk,

    I’m not sure to be honest with you, could you try deactivating all plugins to see if that makes any difference please?

    Best regards,


    I have fixed the issue which was plugin related.

    The plugin is named EventON and it also requires a Google Maps API which wasn’t validated.

    I validated the same API in both the theme and the plugin and this resolved the issue.


    Hi mp3dk,

    Glad you got it working for you! :)

    If you need further assistance please let us know.

    Best regards,

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.