Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
  • #922744

    Hi Guys!

    I created a Google Static Maps API key as per instructions and entered it into the Google Maps section of Google Services in Theme Options. I click the Check API Key button, and right below the key and the button it says, “Could not connect to Google Maps with this API Key.” Hoping this might an anomaly, I went to the page and added a Google Map element. However when I entered the address and clicked fetch coordinates, I got the following error: “An error occurred. It seems that your Google API key is not configured correctly. The key is probably either restricted to the wrong domain or the domain syntax you entered is wrong.”

    At first I tried using it as a restricted key, but when that didn’t work, I tried making it unrestricted. I even waited until the next day in case the Google systems needed time to update, but I still get this error.

    Any ideas???




    Hey scotthco,

    Have you followed the documentation properly

    We are afraid you need to go through it as there are not a lot we can do from our side.

    Best regards,


    I saw a note that “Google requires web sites to be on SSL.” Does that mean that even if everything else is set up correctly, Google maps will not work with a site unless the site uses SSL?!?! That’s a load of @)(&%. People don’t enter user names or passwords or any type of sensitive information on my site. Why should I be forced to buy an SSL certificate when it’s completely unnecessary?


    Seriously, does Google in fact require that all sites making calls to their maps api use SSL now? I just need a definitive answer so I can stop wasting time looking for what else might be wrong.



    Same issue here. It works on other sites I build recently with Enfold, but not on the current site I’m working on. I have checked other API keys and compared to the one I have now. They are the same. I have another website NOT SSL in development with ENfold and it works fine. What’s going on?

    Also disabled all plugins and nothing.


    Hi scotthco,

    I do not see any keys on that website. Have you generated the API key?

    Best regards,


    Hi fulanoinc,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Best regards,


    One client website’s API key was generated and it worked. A map was created and used. Now when I visit the Google Services section on this same website, I get the “Could not connect to Google Maps with this API Key” warning. So it worked and now it doesn’t.

    On another website, I generated it a few weeks ago and it’s currently working. Now I can’t generate it for anything!

    I provided login info. Let me know what you find.


    Hi fulanoinc,

    You mean you cannot generate the API keys in Google console?

    Best regards,


    I have generated plenty of API keys in Google console and have added them. All I get is “Could not connect to Google Maps with this API Key.” Enfold is not recognizing the keys. I turned off all plugins and still not working. I added all the restrictions to the key and still not working. I used an unrestricted key and nothing.


    I have emptied my cache and used other browsers and it does not register. I don’t know what else to do.



    As I mentioned in my initial post, I’ve gone through pretty much the same diagnostic steps that fulanoinc has–no problem simply creating the api keys; created api keys per instructions; tried restricted and specified domains; tried unrestricted–and have gotten the same results: Enfold 4.2.6 Google Maps element NOT working. Says it can’t connect to Google Maps w/that key, and will not fetch coords for the address. I’ve been trying to find something else to replace it, but there’s not much out there that works well. I hope you guys get this fixed soon. BTW – my site is using WP 4.9.4 and Enfold 4.2.6.

    HERE’S AN INTERESTING NOTE: On the contact page for sos4net.com (see link in private content below) there’s a google map element in the left column that was placed there some 2-1/2 to 3 years ago that does not use an api key. This map still works unless I enter an api key in the google services section of the theme options. Once an api key is entered there, the old map element breaks. If the key is removed, the old map element works again.

    After updating to Enfold 4.2.6, I placed a google map element in the right column below the contact form for testing purposes, and that one does not work. I don’t know why the old one on the left is still working, but I would guess that, because it’s been there for some time, it’s not using all the same code, or perhaps it’s already got its coordinates and wouldn’t need to pull them unless I changed the address.

    A client’s site (URLs in private content) is also running WP 4.9.4 and Enfold 4.2.6, and I have the same problem with the google map element for that site as I do with the new one on my site. I created an admin login for Kriesi on that site too.



    I looked at your second site (bbq) and the map is working now, so it seems this is resolved.
    But for the first site (sos) you are getting a 404 error for the map js

    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.[domain].com/maps/api/js?v=3.30

    Which is odd because that is not the right path because the map js is loaded from https://maps.googleapis.com/maps/api/js
    But I can’t find why your site is trying to load the js locally. Please check your custom functions, scripts & plugin options, .htaccess, perhaps I missed this somewhere. Is the site using a CDN?

    Best regards,


    Hi Mike:

    I’m not using a google map plugin or the Enfold google map media element. I’m just using a Code Block, a div (for responsive purposes), an iframe, and the URL for the google map embed api.

    Turns out the JS problem was related to a plugin called Root Relative URLs, which I turned of because I don’t think I need it at this point. After that, the map was actually being created, but it wasn’t visible due to some of the CSS being applied to the div I mentioned above. With that now fixed, it’s displaying like it’s supposed to.



    Glad we were able to help, shall we close this then?

    Best regards,


    The easy 30-second workaround to Google’s confusing menu system is to skip the Google route and enter the coordinates manually by searching with this tool.


    If you want to mine through the Google Maps settings, find the Geocoding Service API and enable it which now seems to be disabled by default.



    , thanks for the tip.

    Best regards,


    I had the same problem. I opened up the Developer Tools in Chrome and checked the response of the request:


    There is an error message, which will give you more detail why it didn’t work. For me: I had to enable billing details in my google account.

    To the developer of Enfold: Please display this error message to the user. That would saved me an hour of debugging.



    Thank you for the feedback, and glad to hear you have sorted this out. I will bring this to the dev team’s attention.
    Thank you for using Enfold.

    For your information, you can take a look at Enfold documentation here
    For any other questions or issues, feel free to start new threads in the Enfold forum and we will gladly try to help you :)

    Best regards,

Viewing 19 posts - 1 through 19 (of 19 total)
  • The topic ‘Google Maps Not Working’ is closed to new replies.