Viewing 30 posts - 1 through 30 (of 30 total)
  • Author
    Posts
  • #804516

    Hi, I created the api key in google console, I enabled map API, I put the api key in enfold space, I find the coordinates in the map but on the page I see this message “Google Maps was not loaded correctly. For technical details, consult the JavaScript console. ”

    My version of enfold is 4.0.5, I’ve created other websites previously and with the same procedure everything worked, because now it does not work anymore?

    #804859

    Hey vbonora,

    Could you try updating the theme to the latest version (4.0.7) to see if that helps please? http://kriesi.at/documentation/enfold/updating-your-theme-files/

    Best regards,
    Rikard

    #804971

    Hi, thanks for the quick reply, I updated the theme correctly but the map continues to fail. The Api key is created correctly and the site is verified, I do not understand why it does not work

    #804975

    I tried inserting various types of refferers maybe they are wrong? Thanks in advance

    #805036

    I do not know if it can be helpful but the javascript console says “NoApiKeys Warning
    The script element that loads the API has no API key. Please make sure you include a valid API key as a key parameter. You can generate a new API key on the Google API Console. “
    … but the api key is present in the enfold space

    #806205

    Hi,

    Do you mind please to redo the process, and add again the site and add new API key?

    Best regards,
    Basilis

    #806866

    Sorry, but the site is practically in production, the enfold version is the latest and the wordpress version is the latest one, why should I do everything from the beginning? The problem is with enfold that does not recognize the API, I do not understand why if I reinstall the same version I should fix the problem …Sorry but it does not seem like a smart solution, making the site from the beginning for the second time would be a cost of production not indifferent

    #806867

    The api key has been re-created, but it still does not work, i would honestly want to avoid doing everything from the beginning

    #807050

    I do have a similar problem with not loading the Google Maps API within Enfold.
    It keeps saying in console: ‘Google Maps API error: ExpiredKeyMapError’. Despite generating new keys, the error doesn’t go away. :(
    I’m running version 4.0.7 and WordPress 4.8.

    Edit: One of our other clients with Enfold 4.0.2. has exactly the same error. Also this website was updated a short while ago to Worpress 4.8.

    (Another client which Enfold version is 4.0.4. and WordPress 4.7.5. has no problems at all and Google Maps API is working correctly.)

    It looks to me, like Enfold theme doesn’t work very well with WordPress 4.8.

    Please help us fixing this issue for our clients.

    Thanks in advance,

    thewebfanatics

    #807097

    “I tried inserting various types of refferers maybe they are wrong? Thanks in advance”
    what form do they have.

    i have had never problems with that – if on google site the wildcard is placed right.

    so if there is in the list : *mywebsite.com/* in most of the cases it works perfect – only sometimes i have to verify the url on google webmaster tools

    PS : the thing with entering the last asterix on google is that it has to be followed by a space – otherwise the last asterix is lost

    PPS: or do you have installed any other map-plugins

    • This reply was modified 3 years, 3 months ago by  Guenni007.
    #807296

    Hi! The site is verified with all available methods. I’ve always followed the same procedure with all the sites I’ve made and it has always worked. I have not installed any plugins for the map

    #808212

    Hi,

    Can you post us a screenshot of the google console?

    Best regards,
    Basilis

    #808476

    Of course, I tried to put all the possible refferers, but nothing.

    #808477

    Of course, I tried to put all the possible refferers, but nothing.

    #809664

    Hi,

    The API key is incorrect. Please check it carefully. This is the error in the console.

    js:35 Google Maps API error: MissingKeyMapError https://developers.google.com/maps/documentation/javascript/error-messages#missing-key-map-error

    Best regards,
    Ismael

    #809708

    This is not the solution to the problem, unfortunately.

    It has something to do with Enfold in combination with WordPress 4.8.

    #809734

    Hi Ismael, the error you have reported is the first thing I have verified .. I have created the api key several times before I write to you, honestly I think it is obvious that the problem is the latest version of enfold with wordpress 4.8, So after spending over 2 weeks, I really need to solve the problem for my client.

    The api key is correct, the site is verified, the refferers are inserted correctly. There is some problem with the latest version of enfold and wordpress 4.8 because the map loads correctly for less than 1 second, then the error appears. It’s been so long since the first report I made and for my clients this is a problem, please help us solve the problem, if it is not possible then give us a valid alternative with enfold

    #810454

    Still waiting for a solution….

    #810467

    Sorry, but now the situation is urgent…

    #810925

    Dear Kriesi, I’m sorry to be insistent, but the situation has become unfortunate.
    For more than two weeks I’m writing about this big problem, the answers given by your staff are superficial and inconsistent with what has been written in previous posts.
    I am not the only one to have encountered this problem and now it is necessary to have an answer that has meaning, positive or negative at this point does not matter, just enough to make sense.
    I can not continue to invent excuses with my client, let me know if there is a solution or not, just know it. If the theme does not work, let me know. We will find a different solution without ever wasting time. I’m sorry because I understand the great work you do and I do not want to seem arrogant, I just want to know what to do before it’s too late.

    #810938

    Also, I’ve tried the same API key on a site that is not updated to wordpress 4.8. It works perfectly..

    • This reply was modified 3 years, 3 months ago by  vbonora.
    #811046

    I can confirm this. On WordPress 4.7.5 it’s working perfectly, but on WordPress 4.8 it doesn’t.

    It would be nice if you come up with a fix for this. My clients are getting impatient, since this problem occurs almost two weeks now…

    #811138

    Hi, I have the same problem.
    I have enfold 4.0.7 on wordpress 4.8
    I created the api key in google console, I enabled API with the pluggin API KEY for Google Maps, I put the map in my contact page, I find the coordinates in the map but on the page I can see the map just 1 second, and then I see this message “Google Maps was not loaded correctly. For technical details, consult the JavaScript console.”

    My situation is urgent too. Do you have the solution??

    (*sorry for my english I do not write really good)

    #811393

    Hi,

    @vbonora: I used my own API key and added the site as http referrer but it’s still not working. It started to work after deactivating the plugins.

    *studiomore.it/*
    http://studiomore.it/*
    

    I think there’s nothing wrong with your API key but one of the plugins is not compatible with the theme.

    Best regards,
    Ismael

    #811399

    Hi Ismael, thank you so much!
    I found the plugin that caused problems, “team booking” that works with google calendar API Key.
    I also added the google map API key into the plugin and I reactivated it again, now everything works. thank you very much. Once again I think enfold is a great choice! :) :)

    #811506

    Hi,

    Great, glad we could help and sorry for the problems. Please let us know if you should need any further help on the topic or if we can close it.

    Best regards,
    Rikard

    #811714

    Hi Rikard,

    For me this doesn’t solve the problem, since I don’t have any plugin installed which uses the Google Maps API.

    #811948

    Hi thewebfanatics,

    I see that you have started a new thread, should we focus on helping you out there?

    Best regards,
    Rikard

    #986673

    The easy 30-second workaround to Google’s confusing menu system is to skip the Google route and enter the coordinates manually by searching with this tool.
    https://www.latlong.net

    OR

    If you want to mine through the Google Maps settings, find the Geocoding Service API and enable it which now seems to be disabled by default.
    https://developers.google.com/maps/documentation/javascript/geocoding

    #987502

    Hi Jasmer,

    Thank you for your input.

    Best regards,
    Victoria

Viewing 30 posts - 1 through 30 (of 30 total)

You must be logged in to reply to this topic.