Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #1304970

    Hi there,
    I’m having some issue with my custom marker for Google Maps.
    It doesn’t seem to be changing to the size I prefer (when adjusting in the “Custom Map Marker Image Size” dropdown).
    Is there a way to tackle sizing this by adjusting the custom CSS or in the functions.php file?
    If so, will that affect both in-page maps as well as widget maps?
    Thanks much!

    • This topic was modified 2 years, 11 months ago by soapboxstudio.

    Hey soapboxstudio,

    I can’t see any problems on my end, the marker is 80×80 pixels like you have selected in the element options. Please see screenshot in private.

    Best regards,


    Hmm… very strange. It’s not showing like that for me (I checked multiple browsers, so I don’t think it’s a cache issue). See attached screenshot in private.

    That being said… is there a way to make the size larger still (via CSS or otherwise)? Say if I wanted it to be 100x100px?
    Thanks again!



    This is possible but you have to add the option directly in the enfold/config-templatebuilder/avia-shortcodes/google_maps/google_maps.php file. Look for this code around line 531.

    							'name' 	=> __( 'Custom Map Marker Image Size', 'avia_framework' ),
    							'desc' 	=> __( 'How big should the marker image be displayed in height and width.', 'avia_framework' ),
    							'id' 	=> 'imagesize',
    							'type' 	=> 'select',
    							'std' 	=> '40',
    							'required' 	=> array( 'marker', 'not', '' ),
    							'subtype' => array(
    												__( '20px * 20px', 'avia_framework' )	=> '20',
    												__( '30px * 30px', 'avia_framework' )	=> '30',
    												__( '40px * 40px', 'avia_framework' )	=> '40',
    												__( '50px * 50px', 'avia_framework' )	=> '50',
    												__( '60px * 60px', 'avia_framework' )	=> '60',
    												__( '70px * 70px', 'avia_framework' )	=> '70',
    												__( '80px * 80px', 'avia_framework' )	=> '80',

    Best regards,


    Thank you guys! Now if I can figure out this browser/caching issue I’ll be all set!



    I checked your website and marker shows 80x80px on my end as well. I attached a screenshot in private content field below.

    Have you figured out the cache issue? :)

    Best regards,


    No… Chrome, FF & Safari are all showing 40px still. Not sure if it’s a cache issue or some browser setting overriding things!
    The only browser it seems to show correctly for me is IE. I appreciate your guys’ follow up though! (excellent service as usual)
    You can mark this one as closed.

Viewing 7 posts - 1 through 7 (of 7 total)
  • The topic ‘Google Maps Custom Marker Size’ is closed to new replies.