Tagged: ,

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1178063

    When I try to input my Google maps API I get this error:

    “Could not connect to Google Maps with this API Key”

    I have followed all the steps in your tutorial, tried restricted keys, unrestricted keys, old keys, new keys, keys that work on other websites, and both with and without billing accounts attached. Everything is updated and I’ve tried with all plugins turned off. It just won’t work for me. Please help!

    #1178284

    Hey cadema,

    Thanks for the login details, could you upgrade the account to have admin rights please? Otherwise we can’t access the theme options. This is the error message you are getting from Google Maps: https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys

    Best regards,
    Rikard

    #1178581

    My mistake – I changed your user permissions to ‘administrator’.

    #1178689

    Hi,

    Thanks for that, this is the error message I’m seeing on your site now: https://developers.google.com/maps/documentation/javascript/error-messages#api-not-activated-map-error

    The Maps JavaScript API is not activated on your API project. You may need to enable the Maps JavaScript API under APIs in the Google Cloud Platform Console.

    Could you try that out please?

    Best regards,
    Rikard

    #1178888

    That did the trick! Thank you, thank you!

    Google has certainly made this more complicated than it need to be.

    #1179214

    Hi cadema,

    Glad you got it working for you! :)

    If you need further assistance please let us know.

    Best regards,
    Victoria

    #1182237

    Hello,

    I am having the same issue and have activated my API correctly. Please HELP

    #1182494

    Hi SK722,

    Could you add the key to the theme backend and save it please? Otherwise we can’t see which error messages you are getting from Google Maps.

    Best regards,
    Rikard

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.