Tagged: , ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #1109956

    I am not sure when the trouble began, but it seems like it was in the last couple of weeks. The map in the footer of my site and on the Contact Us page both began displaying, “Oops! Something went wrong. This page didn’t load Google Maps correctly. See the JavaScript console for technical details.”
    The JavaScript Console reports: “js?key=AIzaSyA4IrtA3dmsQSiyWIBhjoFHPnZ1_S9gl5A&ver=3:52 Google Maps JavaScript API error: DeletedApiProjectMapError https://developers.google.com/maps/documentation/javascript/error-messages#deleted-api-project-map-error”

    Here is what I have tried:

    I couldn’t find the original Google account that managed the current API key to make sure billing was turned on so I generated a new one per the Kriesi.at support instructions, including uploading the file Google generates to verify I own the domain, etc. I turned billing on and verified payment method, etc. The domain has been verified as belonging to the same account that generated the API Key.

    I updated the Theme to the latest version, having read that recommendation made to others with this issue in the support forum.

    In theme options, when I do Check API Key, it returns “We were able to properly connect to google maps with your API key” so it is apparently set up correctly. So I don’t know why I get a JavaScript API error: DeletedApiProjectMapError in the Console for the map containers and the Oops! message in the map containers.

    I added Restrictions to the API, (Maps Static API, Maps JavaScript API, Geocoding API and https://www.mydomain.com/ https://*.mydomain.com/* *.mydomain.com/*) and the Theme Options still says it is able to connect with the API, but I still get the Oops! message in the map containers.

    I have cleared the cached multiple times and flushed the rewrite rules. Still broken.

    Then I did the whole process AGAIN, with a NEW API key with no restrictions on the API. Still, no love.

    Lastly, I disabled all my plugins to see if it would help. It did not.

    Extremely frustrating and time consuming. So, I am now posting my experience and requesting support.

    Note I am using a child-theme, but I don’t know why that would matter.

    If you are able to solve the issue, please let me know what you did to fix it. Thank you!

    Posting creds privately.

    • This topic was modified 4 years, 11 months ago by zac51.

    Hey zac51,

    Best regards,


    Victoria, THANK YOU! That fixed it.

    Your response was private, but for the benefit of others having this frustrating experience, here is how my problem was solved. There was some google maps API code in the functions.php file of my CHILD THEME. I commented it out and the maps began working again. Below is what my code looked like. If you have similar code, you may want to try commenting it out to see if it helps.

    function ava_googlemaps_apikey() {
    	$prefix  = is_ssl() ? "https" : "http";
    	wp_register_script( 'avia-google-maps-api', $prefix.'://maps.google.com/maps/api/js?key=AIzaSyA4IrtA3dmsQSiyWIBhjoFHPnZ1_S9gl5A', array('jquery'), '3', true);
    add_action('init', 'ava_googlemaps_apikey');
    • This reply was modified 4 years, 11 months ago by zac51.


    Great, I’m glad that you got it working and thanks for sharing your solution. Please let us know if you should need any further help on the topic or if we can close it.

    Best regards,

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.