Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
  • #813623

    Dear all,
    I am using the content element Google Map, but now I getting the message that something went wrong and Javascript – Console. Can please check what is needed, as this Google Map element is an important part of the website.

    Thanks for the support!


    Greetings Support. Similar issue. Resulting error when trying to add address:

    An error occurred
    It seems that your Google API key is not configured correctly
    The key is probably either restricted to the wrong domain or the domain syntax you entered is wrong.
    Please check your API key here
    The domain that should be allowed is:*

    My key is pasted into the google services section of Enfold Theme Options.

    I have reconfigured my API key and referrers multiple times with many possible variations as mentioned in step 4 of your google maps tutorial:

    I have also disabled all plugins.

    I have also cleared cash/ logged out/ in multiple times.

    Please send further tips on how to correct.

    Thank you very much.


    Just to let you know.
    I also tried the steps explained, but still Google Maps doesn’t show.

    Looking forward to the reply as the Google Maps content element is used on multiple pages.


    @michael_world2cycle: Agreed.

    Kriesi Support, do you have any suggestions for us?


    Hi tom3321,

    I see the map loading fine and without errors. Seems like the key started working or did it not?

    Best regards,


    Hi michael_world2cycle,

    The text of the error below. You need to authorize your website in Google console.

    Best regards,


    Hi Victoria,

    As you can see, this is a photo of a map. It is not in fact a live Google map. This is a very crude workaround, I was not sure if Support would respond before launch.

    I’ve added the google map media element back to the staging site, see link below.

    Please advise how to correct API issue.

    Thank you,


    Hi @tom3321,

    Please, to avoid any confusion, could you create a new thread with your problem and the details?

    Best regards,
    John Torvik


    @John. Yes, I have created a new post. Please review #815094 and advise.


    Hi tom3321,

    I just replied to your thread, please stick to that from now on.

    Best regards,


    Can you maybe have a second look about how it can be that we have different API key’s. (see private message)

    This is the information included in Google Maps API key in Enfold.
    For this key I authorized my website entering the following* and **

    Thanks :-)



    I remembered using my own API key on your site and forgot to changed it. I deleted the site as one of the http referrers, thinking that you already have your own, and that’s why it’s not working now. Please create a new project and generate your own API Key.


    Previous thread:

    Best regards,


    Thanks for the effort.
    I did generate a new API. See private details, but still it doesn’t seem to work.


    Hi michael_world2cycle,

    Try also adding the link like this **, without the dot.

    If you need further assistance please let us know.
    Best regards,


    Thanks Victoria,
    I did make the adjustment as suggested, but still it doesn’t seem to work.
    Can you please have a second look.

    If you need any furter details, please let me know.



    Hi michael_world2cycle,

    There seem to be 2 apis included, are you doing it with a plugin as well?
    They use different keys.
    Best regards,


    Thanks Victoria, the correct API should be the one confirmed in the private data. At first I created an API, but was done by using the incorrect Gmail account. I did already confirmed this by Google Services in Enfold, and later on replaced the API with the correct details as shared with you in the private data. Can you please let me know, how this can be solved, as it seems that the API key is not overwritten. Can this be the result of the error…?, that will be great news, if that is the case.



    We removed the following code from the functions.php file.

    function ava_googlemaps_apikey() {
    	$prefix  = is_ssl() ? "https" : "http";
    	wp_register_script( 'avia-google-maps-api', $prefix.'://', array('jquery'), '3', true);
    add_action('init', 'ava_googlemaps_apikey');

    Best regards,

Viewing 18 posts - 1 through 18 (of 18 total)
  • You must be logged in to reply to this topic.