Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1126682

    Hi,
    i tried not to use google fonts in any way. I’m using websafe fonts in the theme (helvica neue).

    Now i did a website speed check of my website on: https://tools.pingdom.com/
    I check it and found:

    https://fonts.gstatic.com/s/roboto/v18/KFOmCnqEu92Fr1Mu4mxK.woff2
    https://fonts.gstatic.com/s/roboto/v18/KFOlCnqEu92Fr1MmEU9fBBc4.woff2

    are loaded on my website.

    It seems google fonts are still active somewhere? Could someone please check it and please tell me, how i can disable google fonts totally?
    I don’t want to get trouble because of this with DSGVO.

    kind regards

    Jak

    #1126684

    Hi,
    i think i found the issue. It seems if recaptcha v3 is loaded, it loads:
    https://fonts.gstatic.com/s/roboto/v18/KFOmCnqEu92Fr1Mu4mxK.woff2
    https://fonts.gstatic.com/s/roboto/v18/KFOlCnqEu92Fr1MmEU9fBBc4.woff2

    When i remove recaptcha v3, it seems google fonts are not loaded.

    Could somebody please check my page for google fonts? Would be nice, because i’m not sure, if google fonts still loaded?

    Many thanks in advance!

    kind regards Jak

    #1126908

    Hi Jak73,

    I don’t see Roboto loading right now, do you have reCaptcha disabled?

    Best regards,
    Victoria

    #1126911

    Hi Victoria,

    yes i disabled recaptcha, but i’m not sure, if the loading came from recaptcha.
    I’m very confused. It seems there is “Palatino Linotype”,”Book Antiqua”,Palatino,serif; as google fonts loaded. Maybe from the newsletter popup. Could you please have a look?

    kind regards Jak

    #1127406

    Hi,

    On our next update, this issue will be shorted out.

    Best regards,
    Basilis

    #1145860

    Please what is the status on this? I am not fond of having calls to external domains such as gstatic.com beyond my control.

    #1145885

    it is your map! google map loads this font, right`?

    #1146069

    Hi Royaltask,

    I don’t think it is Google maps, I have disabled it under Google service settings in the theme. The only think I have is an external link that opens up in a new window: https://www.google.se/maps/place/Aptilo+Networks+AB (Email address hidden if logged out) ,18.0771996,17z/data=!3m1!4b1!4m5!3m4!1s0x465f7826d9e9aadb:0xe5a6eb7fefaa0c6e!8m2!3d59.2942141!4d18.0793883

    I don’t think that this call can trigger loading of gstatic.com fonts?

    It can’t be any plugin either as gstatic.com call is still there after disabling all plugins.

    /

    #1146703

    Hi,

    Thank you for the update.

    The font is either loaded by the recaptcha or the google map services. It is the font used in their widgets. Why are you trying to disable it? There is a way to prevent the font from loading, but it’s not implemented in the theme.

    // https://stackoverflow.com/questions/25523806/google-maps-v3-prevent-api-from-loading-roboto-font

    Best regards,
    Ismael

    #1146791

    Thanks Ismael,

    I have disabled both recapthca and google maps under Google services in the team, but the font still loads. The reason I want to diable it is that I want to minimize unneccesary calls to external servers and that the loading of the font causes delays in the rendering of the page.

    #1146815

    Breaking news ;=)). It was user error – my bad. I didn’t realise that that our designer had chosen a Google Webkit font called Open Sans. Now I will have to find a “web safe font” that is as close as possible. Question:

    I am thinking to upload an Open Sans font and use that instead locally. But, I guess it will not be as fast rendering as the “Web safe fonts?”

    #1147025

    Hi Terve,

    Thanks for the update. Using a custom font will likely add more load time to your site compared to using a web safe font yes.

    Best regards,
    Rikard

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.