Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #697766

    I added a google font (Heebo) to my site with the action as suggested here:
    https://kriesi.at/support/topic/add-new-font/#post-234710

    Problem is that it works only on Google chrome, but on other browsers (I tried IE, Edge and Safari on MAC) it seems like the font doesn’t load and “Arial” is displayed instead.

    I also added these lines to the Quick CSS part in the theme settings:

    @import url(//fonts.googleapis.com/css?family=Heebo:400,500,700&subset=hebrew);
    
    /*הגדרת פונט ל-HEEBO*/
    html, body, div, span, applet, object, iframe, h1, h2, h3, h4, h5, h6, p, blockquote, pre, a, abbr, acronym, address, big, cite, code, del, dfn, em, img, ins, kbd, q, s, samp, small, strike, strong, sub, sup, tt, var, b, u, i, center, dl, dt, dd, ol, ul, li, fieldset, form, label, legend, table, caption, tbody, tfoot, thead, tr, th, td, article, aside, canvas, details, embed, figure, figcaption, footer, header, hgroup, menu, nav, output, ruby, section, summary, time, mark, audio, video{
       font-family: 'Heebo', Arial, sans-serif;
    }

    But it seems like it doesn’t help.

    Do you know how to fix the problem and make the font displayed on all platforms?

    #698278

    Hey barak97,

    Try to remove “Arial” from your code. Clear browser cache and hard refresh a few times.

    I noticed that you are using a caching plugin. Would you mind opening your plugin’s settings page and temporarily deactivate the caching of your site? Then please try to clear your browser cache and hard refresh the site (Hold CTRL + SHIFT + RELOAD) to see if that solves the issue.

    Best regards,
    Andy

    #698549

    I removed “Arial” from the code.
    I forgot to mention in my first message, but I obviously selected “Heebo” as the default font in the theme options.

    I turned off the cache plugin and followed your instructions, but the font still was Arial when I used IE and Edge… :(

    #699073

    Hi,

    did you switch off the caching function of your cache plugin, before deactivating the plugin itself? this is crucial, otherwise caching will still go on.

    Please check on another computer as well.

    Best regards,
    Andy

    #699351

    I use WP-ROCKET, and I didn’t see a way to disable the caching function for the whole site, but only for certain pages.
    So I disabled the caching for the page that is in the Private Content section (The 404 error page), and it seems like the problem still occurs.

    #699399

    Hey!

    Your site seems to be cached and that cache is not allowing your changes to go live.
    Can you please disable WPRocket while you work, so we can also be able to help you?

    Thanks a lot

    Cheers!
    Basilis

    #699615

    Hi,

    Now the caching is supposed to be disabled.

    • This reply was modified 7 years, 6 months ago by barak97.
    #700983

    Hi,

    The font file is loaded when I checked the page on Firefox and Chrome.

     	<link rel='stylesheet' id='avia-google-webfont' href='//fonts.googleapis.com/css?family=Heebo' type='text/css' media='all'/> 
    

    Are you familiar with browser inspector or “view page source”? Let us know if you can find that line in those browsers.

    Best regards,
    Ismael

    #702947

    Hi, of course it works on chrome… This is not the problem! See first message.

    #703622

    Hi,

    Yes, I know that it is working on Chrome. That’s why I asked you if you can find that line on Firefox or Safari or any browsers except chrome. Please let us know if you can find that line on those browsers.

    Best regards,
    Ismael

    #703633

    Hi,

    Please try this code in the functions.php file.

    add_filter( 'avf_google_heading_font', 'avia_add_heading_font');
    function avia_add_heading_font($fonts)
    {
    $fonts['Heebo'] = 'Heebo:400,500,700&subset=hebrew';
    return $fonts;
    }
    
    add_filter( 'avf_google_content_font', 'avia_add_content_font');
    function avia_add_content_font($fonts)
    {
    
    $fonts['Heebo'] = 'Heebo:400,500,700&subset=hebrew';
    return $fonts;
    }

    Set the font in the Enfold > General Styling > Fonts panel.

    Best regards,
    Ismael

    #708155

    Thanks, Ismael!
    Looks like it works now :)

    #708574

    Hi,

    Great, glad we could help :-)

    Please let us know if you should need any further help on the topic.

    Best regards,
    Rikard

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.