Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1219783

    Hallo,

    Situation, wenn man im Menü mouseover macht, öffenet sich ein untermenüpunkt (sub1), geht man da drüber, öffnet sich mehrere unter menüpunkte(sub2).
    Wenn man jetzt von sub1 mit der Maus zu einem unteren punkt von sub2 geht, so verschwindet das Menü wieder, weil man kurzs durchs “leere” die Maus zieht.

    ich habe hier mich mit mouseleave befehl und fast und slow in der avia.js datei rumgetestet, aber leider hat es nicht funktioniert.

    Meine Frage:
    Geht es überhaupt, das man bei mouseleave noch wieder in mouse_in reinkommt? :)
    Wenn ja, wo kann ich da was ändern?

    Danke!

    #1220229

    Hey beste_medien_werbe_agentur,

    Please have a look at the following thread:
    https://kriesi.at/support/topic/submenu-hidden-delay-time/

    If you need further assistance please let us know.

    Best regards,
    Victoria

    #1220276

    hey Victoria!

    outdated :)
    (not even sublist.stop exist) .

    but if it would work, it would be my solution

    Best Regards
    bmwa

    #1220299

    Hi bmwa,

    Oh, it actually exists. It moved to a different file:
    enfold/js/avia-snippet-megamenu.js

    Image 2020-06-07 at 21.48.24.png

    Could you please give us a link to your website, we need more context to be able to help you.

    Best regards,
    Victoria

    #1220415

    Hi Victoria,

    you are great!

    the delay works, BUT:
    it disappear after i fast enough to mouseover to the next submenu, but it still disappear :)

    in Private content you can check out, i put successfully delay 300. you can try it out when you go:
    First Menu -> Zimmer -> now go with the mouse direktly to “Fotos”.

    #1222075

    Hi beste_medien_werbe_agentur,

    Please try a longer delay, like 500 or 700ms, and see if the issue gets fixed.

    Best regards,
    Victoria

    #1222112

    Hi Victoria,

    unfortunately still the same effect @700.

    #1227277

    Hi,

    We are sorry for the late reply!

    Would using your first menu item as Mega Menu or separating “hotel” and “zimmer” be an acceptable solution for you? It seems like adding delay is not really working properly instead causing hiccups. I attached a screenshot where you can see submenu is hidden when hovering on main menu item.

    Best regards,
    Yigit

    #1227424

    Hi Yigit,

    i dont understand what exactly you mean, but yes, i will fix it like separate hotel and zimmer if we dont find a solution. So no worries.

    I hoped only, that a fix exist generaly for this problem.

    So, everything is fine. Thank you for your time of investigation :)

    #1227425

    this is not an exclusive enfold trouble – it is the old “diagonal submenu hover problem” – and google on that – it is a well known problem of multi-level drop-down menus.

    Maybe this is a nice first info on it: https://css-tricks.com/dropdown-menus-with-more-forgiving-mouse-movement-paths/

    #1227426

    Guenni007 = Awesome

    #1227456

    Hi,

    You are welcome! Let us know if you have any other questions or issues :)

    @guenni007 Thanks for your help :)

    Best regards,
    Yigit

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘German/Deutsch: mouseleave Sub_menu zeit erhöhen’ is closed to new replies.