Viewing 29 posts - 1 through 29 (of 29 total)
  • Author
    Posts
  • #947780

    As the subject says, since the last version of Enfold background images for elements get converted to a wrong path
    (even if I manually set them relative via CSS).

    Example:
    http://wordpress.p4580xx.webspaceconfig.de/wp-content/uploads/dynamic_avia/wp-content/uploads/2018/04/textur_dunkel.jpg

    Already turned of plugins etc. Seems to be an internal problem.
    Any ideas?

    #948533

    Hey boehm.media,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Best regards,
    Victoria

    #948848
    This reply has been marked as private.
    #948894

    Hi,

    I resaved your permalinks settings.

    And tested the background images on ALB grid element and it works fine.

    If you still have an issue please let us know exactly how we can reproduce the issue.

    Best regards,
    Vinay

    #948977

    The normal element backgrounds it work fine, but the Enfold Theme Settings – backgrounds don’t.
    For example – I’ve chosen “gradient-top-dark” for the “Logo area”, as you can(‘t) see – it adds a wrong absolute path.

    #949085

    Same problem on two pages with me!
    The URLs gets changed to something like: >https://www.domain.de/wp-content/uploads/dynamic_avia/www.domain.de/wp-content/themes/enfold/images/background-images/floral-dark.png

    Further more: This also happens when i turn off the enfold backgound and try to create a background manually in the quick css.
    In the Quick CSS i use the URL https://www.domain.de/wp-content/uploads/2018/04/f-dark.png but the CSS output gets changed to: https://www.domain.de/wp-content/uploads/dynamic_avia/wp-content/uploads/2018/04/f-dark.png

    So in my opinion Enfod adds this part “https://www.domain.de/wp-content/uploads/dynamic_avia/” to all CSS Background URLs.

    #949110

    Yes, as I said… has to be a bug in the new version :-(

    Please hurry up Enfold guys, I need a solution asap.

    #949890

    @vinay @victoria
    still no workaround / solution?

    • This reply was modified 3 years ago by  boehm.media.
    #949921

    Hi,

    We have forwarded the issue to our developers. To fix the issue temporarily, just copy the css code and put the correct path. Put it on the Quick CSS field to override the one with the invalid path.

    Best regards,
    Ismael

    #950001

    Ok.

    As I said above, I already did that…
    Enfold even adds the “../dynamic_avia/…” path to direct CSS :-(

    Please let me know, when an update is available for that. Thanks!

    #951213

    Hi,

    @boegm.media: Please try to disable the Performance > CSS file merging and compression option temporarily. Use another plugin like “Autoptimize” or “BWP” for now.

    Best regards,
    Ismael

    #952551

    Hi!

    We would like to implement a few changes in your installation. Please provide the WP/FTP login details. Or edit the config-templatebuilder > php > asset-manager-class.php file, replace everything with this code.

    // https://pastebin.com/T4aYxGX4

    Don’t forget re-minify the css files aflterwards.

    Cheers!
    Ismael

    #1081492

    Ismael, this same bug is back with the latest Enfold update 4.5.5 as I have a “Custom Background Image” set to my body on the Theme Settings > General Styling and it isn’t showing anymore

    #1081587

    I’m having the same trouble. We upgraded to 4.5.5 today and the URL path on CSS referenced background images started throwing 404 errors. The URLs were repeating the domain (ex., https://mywebsite.com/mywebsite.com/wp-content/uploads/2019/03/myimage.jpg). We couldn’t get it corrected until we rolled back the Enfold version.

    #1081918

    I noticed this same issue. I disabled CSS file merging and compression, and that resolved the error. I look forward to a better solution. Thanks!

    #1082355

    Hi AJDesignCo,

    Thank you for your input, yes it should be fixed soon, sorry for the inconvenience.

    Best regards,
    Victoria

    #1083647

    thanks, AJ Design I disabled CSS and JS compression and the background header and footer images cam back.

    I have also noticed that on the mobile version of the Chrome browser that some embedded images in the content seem to also not be showing up in my content anymore since updating enfold. It seems to be pretty consistent on which ones although I haven’t found any commonality. Some are links to YouTube videos while others are just static. Will test this some more and if I can’t clear it up after disabling other plugins and clearing the cache I’ll share a few affected page links

    #1083669

    So here is what I noticed in addition to the header/footer background images no longer showing up with CSS Compression is enabled via the Theme Settings in Enfold 4.5.5.

    4 Issues Since The 4.5.5 Update:
    —- Background images in header area black once CSS Compression is enabled

    —-Some theme functionality disabled once JS Compression is enabled.
    Example: My shrinking and sticky header on desktop stays as full-sized Logo Left Menu Below when enabled instead of shrinking on scroll as it does now.

    —-The Mobile Burger menu no longer shows up once you enable Combine JavaScript files through any caching plugin including WPRocket which it did not do prior to this update.

    —-images are often hidden on the mobile version of Chrome although they show on the Firefox mobile app and others, haven’t tested safari. Turned off all caching through WP Rocket as well as setting through the Theme Performance and it does not help. They show on desktop when you shrink the browser but not on an actual mobile device
    Example 1: https://www.bigboytravel.com/
    Example 2: https://www.bigboytravel.com/europe/austria/salzburg/soundofmusicfilmlocations/

    #1085724

    Hi,

    @millertimesites: Did you set jQuery to load in the footer? This is the error in the console.

    (index):64 Uncaught ReferenceError: jQuery is not defined
    at (index):64

    Looks like an issue with html minification. Please disable the plugins temporarily.

    Best regards,
    Ismael

    #1086985

    Hi,
    I have exactly the same problem.
    Here’s the situation : I have four small websites ( one simple page ) with the exact same setup where the background is showing with no problem.
    I’m, at the moment, building a fifth page that is going to be the “access portal” for the other pages, it’s the same setup as the other pages but, for some reason, the image background is not showing…
    Any idea ?

    In advance, thank you for your help…

    #1088090

    Hi,

    @nnn666nnn: The “serrurerie” site redirects to the “en” version, but it doesn’t exists. Please check the multi-lang configuration carefully. If possible, please create your own thread or ticket.

    Best regards,
    Ismael

    #1092612

    As the subject says, since the last version of Enfold background images for elements get converted to a wrong path
    (even if I manually set them relative via CSS).

    This issue is still there in Enfold version 4.5.6. I hope it will be solved in the next update.

    #1093183

    Hi,

    Did you toggle the file compression settings after the theme upgrade? The modification that was included in the latest patch fixed the issue for a lot of users.

    Best regards,
    Ismael

    #1093384

    4.5.6 definitely did not solve the issue unfortunately, when you enable “CSS file merging and compression” the background images for the logo, body, or footer areas do not show up.

    #1093818

    Hi,

    Thanks for the update.

    We just found out that the fix for the compression was not merged or included in the latest patch. It was unintentional of course. Please update the asset-manager.php file as described in this thread.

    // https://kriesi.at/support/topic/again-one-problem-with-merged-css/#post-1082689

    We would like to apologize for the inconvenience.

    Best regards,
    Ismael

    #1098992

    We just updated Enfold to 4.5.6, but the URL path on CSS referenced background images were still throwing 404 errors. What finally worked for us was we copied the styles in question from Enfold’s custom css into the WordPress css (Appearance > Customize, Additional CSS). The URLs are working fine now. If anyone is having a similar issue, I suggest trying this out for yourself.

    #1099274

    Hi GWS,

    We’re very sorry for the problem, we have a solution already and it will be included in the next release of the theme. Thanks for sharing your solution though, it’s much appreciated :-)

    Best regards,
    Rikard

    #1103943

    Thanks so much GWS! That worked for me too.

    #1104015

    Glad to help! :)

Viewing 29 posts - 1 through 29 (of 29 total)

You must be logged in to reply to this topic.