Tagged: 

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1331066

    The Fullwidth Easy Slider disappears when a custom link with a query on it is added to the menu. I’m assuming this is a glitch? I’ve run tests, and removing everything after the ? in the URL fixes the issue. Unfortunately, we need the query as part of the URL. You shouldn’t need credentials to inspect the code and see that the slider is there but that it’s not displaying. I also can’t leave this up for more than 24 hours because we have to pass along to the client to review ASAP. I can fix it by changing the URL, but wanted you to “see” it first.

    #1331118

    Hey mgyura,

    Thank you for the inquiry.

    There is an extra forward slash in the slider URL (see private field), just after the anchor or the hashtag symbol, which breaks the URL and causes this error.

    jquery.min.js?ver=3.6.0:2 Uncaught Error: Syntax error, unrecognized expression: #church?pin=&presbytery=315528

    Best regards,
    Ismael

    #1331211

    Changing to that URL did not fix the issue. And when you click on that URL, the URL in the browser has the slash – https://ogaapps.pcusa.org/directories/#/church?pin=&presbytery=315528 is copied exactly from the browser.

    • This reply was modified 2 years, 3 months ago by mgyura.
    #1331326

    Hi,

    Thank you for the update.

    The extra forward slash after the hashtag symbol is still in the URL. Please try to use the URL in the private field. Make sure to purge the cache or do a hard refresh afterwards.

    Best regards,
    Ismael

    #1331340

    I have done a hard refresh, purged the cache, tried in a different browser, and tried in a private browser – the slider still does not appear when I use the link that you provided. If I replace the URL with https://ogaapps.pcusa.org/directories/#/church, it works fine, even with the forward slash after the hash tag. It’s definitely the query in the URL that’s breaking the slider. The link that is currently in the menu under Find a Church is as you gave it to me, without the forward slash after the hash tag. Are you seeing the slider now?

    #1331405

    Hi,

    Sorry about that. Looks like you have to move the anchor after the query string (see private field) based on the following thread.

    https://stackoverflow.com/questions/12682952/proper-url-forming-with-a-query-string-and-an-anchor-hashtag

    Thank you for your patience.

    Best regards,
    Ismael

    #1331409

    Thank you, but the query doesn’t work with that link. (It should select Peace River from the Select Presbytery dropdown, which it does with other links that have been posted).

    #1331456

    Hi,

    It should select Peace River

    Did you add a custom script for it? Can we check the code? Please use pastebin or any snippet hosting sites for the code.

    We noticed that the “pin” parameter above is empty. Was that intentional?

    Best regards,
    Ismael

    #1331756

    There is nothing custom about this. We copied the URL directly from the external website and pasted it into the menu item as a custom link (under Appearance –> Menus). Nothing special about any of this.

    It doesn’t matter if the pin parameter is empty or not – I’ve tried as is and removing that parameter. (That parameter is unnecessary for our purposes but was in the URL when we pulled it from the external site).

    #1331786

    Hi,

    Thanks for the update.

    Would you mind disabling the Performance > File Compression settings temporarily? The scripts are minified or compressed, so we cannot identify where the error actually occurs or in which file it originates.

    Nothing special about any of this.

    There should be a script that retrieves the value of the presbytery parameter from the URL and automatically selects the corresponding option in the select element. It is not going to happen automatically, not without a custom script. Are you using a plugin?

    The “Find a church” menu item redirects to a page containing form that filters different items, but it looks like an Angular website, not WordPress, which is probably why the hashtag is added after the site location, and the church is actually a route, not an anchor.

    Have you tried shortening the URL? (see private field)

    Best regards,
    Ismael

    #1331886

    Ah, brilliant! Yes, using the shortened URL worked just fine.

    #1332311

    Hi,
    Glad to hear that the shortened URL worked, shall we close this then?

    Best regards,
    Mike

    #1333018

    Yes, please – thank you!

    #1333054

    Hi,

    Thanks for letting us know, I’ll close this thread for now then. Please open a new thread if you should have any further questions or problems.

    Best regards,
    Rikard

Viewing 14 posts - 1 through 14 (of 14 total)
  • The topic ‘Fullwidth Easy Slider disappears’ is closed to new replies.