Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #924363

    Hi Kriesi-Team.

    Unfortunately, that´s my first REAL problem with my website (log-in data etc. mentioned in the private content).

    After an update of the plugin “Yoast SEO” today, the main menue links of the homepage are directing to blank or error pages (in the frontend).
    There´s still normal access to the dashboard and all functions there – but same problem: when I want to go to a site directly out of the dashboard, I get a blank page.
    Just changing the permalinks to the “normal/simple” standard works without problems (with id-numbers instead of the direction names)
    But unfortunately this is not the best seo-condition…

    However I can not explain this two more things I tried:
    – I also did an backup yesterday (long time before the problem) and restored that backup today – still same problem
    – I also disabled the yoast plugin with the restored backup of yesterday – problem still there…

    Of cause I cleaned the browser cache also several times.

    Thanks for your kind help!

    Greetings
    Manuel

    #924423
    This reply has been marked as private.
    #924444

    Hey Manuel,
    I tried testing your permalink structure issue, but I was having issues with the setting staying selected. Perhaps we were both on the site at the same time?
    What I did see is that when the permalinks use the post name, the word “home” is added to the url, please check the yoast options for it changing the permalinks.

    Best regards,
    Mike

    #924449
    This reply has been marked as private.
    #924454
    This reply has been marked as private.
    #924488

    Hi,
    Thank you, I found that when your permalinks are set to “post name” the word “homepage” is added to your url, and when set to “plain” it is not. Yoast dosn’t seem to effect this, as I test with it on and off. I also found that your .htaccess file is not writable so when updating your permalinks the .htaccess file is not getting updated.
    Please include FTP access so we can view / update.
    I disabled Yoast for now, and set your permalinks to “plain” so your site will work until we hear back from you on the FTP access.
    Naming your startpage “homepage” is fine, it is not what I mean, Please see screenshots in Private Content area.
    Did you migrate this install from a localhost or testing site?

    Best regards,
    Mike

    #924555
    This reply has been marked as private.
    #924972

    Hi,
    I see that your .htaccess doesn’t include the wordpress IfModule mod_rewrite rules:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    you should include this below your AuthType rule, and it would not affect how your AuthType works.
    I couldn’t test because your file has owner / group permissions set to “0 0”
    This makes since as your server path seems to include /homepage/
    Please look on the WordPress > Dashboard > Settings > Permalink Settings, down at the bottom under “Product permalinks” for “Shop base” woocommerce captures your server path.
    That is to say without the wordpress rewrite rules, your server path is pass to the links.
    I hope this makes sense the way I explained it.

    Best regards,
    Mike

    #925391

    Hi Mike.

    Thanks for your reply.

    I added the rewrite-rules and the redirecting is working fine (with site- and productnames instead of the id-numbers) – BUT: the path-addition “…/homepage/…”- is still there, although I changed it in the woocommerce permalinks (like you mentioned it).

    Do you have any idea, how to get rid of this “sticky” woocommerce-setting?

    Also my caching-plugin is disabled / turned off – do you recommend turning it on again oder should this plugin stay disabled?

    Thanks a lot and greetings,
    Manuel

    #925450

    Hi,
    Before you migrated to online, was your path /homepage/ ?

    Best regards,
    Mike

    #925455

    Hi,
    I believe the issue is that most of your pages have listed “homepage” as the parent
    2018-03-12_055237
    Try changing them to “no parent”

    Best regards,
    Mike

    #925516

    Hi Mike.

    Thanks for the tip – it worked! :-)
    For SEO reasons, I always believed, that I have to mention the parent-site in the path.

    So I guess, this thread can be closed.

    Thanks and greetings,
    Manuel

    #925834

    Hi,
    I’m glad this has been sorted out. We will close this now. Thank you for using Enfold.

    For your information, you can take a look at Enfold documentation here
    and the video tutorials here
    And if there are features that you wish Enfold had, you can request them and vote the requested ones here
    For any other questions or issues, feel free to start new threads under Enfold sub forum and we will gladly try to help you :)

    Best regards,
    Mike

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘Frontend error after update: Just homepage working but no links working’ is closed to new replies.