Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #244155

    I successfully uploaded a new icon font that consisted of 3 icons using the tutorial here: (Purchase code hidden if logged out)(Purchase code hidden if logged out) -uploader

    I wanted to add an additional fourth icon, so I deleted the 3 icon font set from the Import/Export Menu in the theme settings as well as from my media library. I then proceeded to upload the new icon font that SHOULD have consisted of 4 icons. This is where I ran into a problem. Instead of showing the fourth icon, it consistently shows ONLY the first three icons. I continued trying different sets with up to 11 icons and each time it still only shows my first 3 icons.

    the icons DO seem to be getting deleted correctly, because each time i delete the old set, they no longer show up in the icon selection (i.e. in the icon box icon gallery). but no matter how many icons i upload in the new set, it only shows the same 3 original icons.

    i’m at a loss. i’ve tried deleting my browser cache on Chrome and i’ve tried using firefox to no avail. please help!


    not sure what happened. i gave up on fontello and used and it worked. thank god. despite this workaround, i’m still interested in a solution if anyone knows what was going on.



    Maybe try to rename the font family and use “fontello-custom” instead of “fontello”. I’ll mark the thread for Kriesi’s attention.



    Actually I am having the same issue. I had to add icons so added a new icon upload and deleted the old one but now only one icon shows up no matter what I upload. I dont know if it is an issue with fontello or with the uploader.

    please advise. thanks


    use the following website instead of fontello:

    it does the same thing as fontello. worked for me.


    thanks, i was just doing that now because i saw your post. but its only giving me option to download as json file. how do you get option to download as zip? sorry to be a pest.


    Did as aschmidt8 suggested and used but still only loading partial lists of icons. Others appearing as blanks. The ones appearing as blanks are not self-created icons, the ones I created are showing up. It is others from font awesome and other icon sets that are failing to load. Though it doesnt seem to be limited to one icon set over another because some of each are loading.


    try this.

    then select your icons (or import using the purple button in the top right). then click “Font” at the bottom. then on the next page click on “Download” at the bottom. after that, you should be able to upload to Enfold and get it working


    hmmm. i found by googling “icon fonts generator”. could be a long shot, but maybe try to find a third website to try. let me know if it works. also, really hoping the admins can find a solution.



    As always, thank you for using the support forum!

    Regarding the original problem, maybe you can remove the original font icon files on wp-content/uploads/avia_fonts folder then upload the icon font zip again. See what happens.

    Best regards,


    Ok, I deleted the last font folder I had uploaded which happened to be icomoon and reuploaded the last fontello-zip file. It seems to have worked for now. the one i created in fontello did not show up but maybe ill try that again later.

    Just an fyi, I never could get the icomoon ones to stay, they eventually disappeared all together, weird. dont know what happened.

    so, yes, it looks like you have to delete it completely from the server and cannot just replace it with a new zip file.




    Glad you found a solution :)



    I have done exactly what you’ve instructed at the blog, and recieve the following error:

    any solution?


Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘Fontello Icon Font issues’ is closed to new replies.