Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #485186

    Hello!

    I’m having troubles with adding font-weight via the Quick CSS and also via the custom.css file.
    The font is Roboto from Google Web fonts and it’s selected through the Enfold admin.

    It works fine adding font-weight: 200; in the Quick CSS and viewed on the front page of the website, but it doesn’t work on any of the subpages, it looks like it stays on 400/normal.

    What is the problem here and how do I resolve it?

    • This topic was modified 2 years, 10 months ago by  grafixstudio.
    #485361

    Hey grafixstudio!

    Please refer to this post and add new fonts weights – http://kriesi.at/documentation/enfold/ (Purchase code hidden if logged out) -theme-options/

    Best regards,
    Yigit

    #485565

    Does it have to be in a child theme? I don’t use a child theme at this moment …

    #485592

    Hi!

    Yes, using a child theme is a good habit to get into, http://kriesi.at/documentation/enfold/downloads/. After activating the child theme you can import your settings in Dashboard > Enfold > Import/Export.

    Cheers!
    Elliott

    #485875

    I have activated the child theme and when I paste the code for the fonts in functions.php it doesn’t work and everything goes blank?

    #485973

    Hey!

    I would like to add the code but the Appearance > Editor panel is not available in the dashboard. Please set the user as admin.

    Regards,
    Ismael

    #486354

    Hey

    User is admin already…You can’t go through FTP?
    Remember the font is Roboto:300

    #486945

    Hey!

    Alright. Please edit the functions.php file then look for this code around line 17:

    if(isset($avia_config['use_child_theme_functions_only'])) return;
    

    Below, add this code:

    add_filter( 'avf_google_content_font', 'avia_add_content_font');
    function avia_add_heading_font($fonts) {
    $fonts['Robots'] = 'Roboto:300';
    return $fonts;
    }
    
    add_filter( 'avf_google_heading_font', 'avia_add_heading_font');
    function avia_add_content_font($fonts) {
    $fonts['Google fonts']['Robots'] = 'Roboto:300';
    return $fonts;
    }

    You’ll be able to select a new font on General Styling > Fonts panel called “Robots”. Make sure that you copy the code directly from the forum, not from your email.

    Cheers!
    Ismael

    #487193

    Hello

    Ok but there is nothing in the function.php for the child theme. I realize you are more people answering my questions but please stay consistent.

    When I add this to either the enfolds regular functions.php or the enfold child functions.php I get a blank screen.

    I still get a blank screen in other words, nothing has changed.

    #487904

    Hi!

    please activate the editor function in your backend (Appearance->Editor) so we can check your functions.php. Are you using a child theme?

    Best regards,
    Andy

    #488686

    Yes I am using a child theme. It seems that a security plugin removed the editor feature. I deactiveated this plugin but it still doesn’t work.
    Please, I have given you FTP-access. Please go through the FTP and make the changes. Or make proper changes to your code so it works, because it doesn’t when I past it in my child themes functions.php

    #488691

    Hello again, I have solved it. You ccan now enter the Editor via WP-admin

    #488899

    Hey!

    I checked your child theme’s functions.php and it is empty. Please insert Ismael’s code into it and let us know when you are done, so we can check if it’s working or not.

    Cheers!
    Andy

    #488928

    Ok, this is getting ridiculous. I’ve already told you that the code leaves a BLANK PAGE your PHP-code is FAULTY!

    Check the DEBUG now. And the Page Specific Menu plugin is not the plugin causing this, I already tried your code without the plugin activated and it still doesn’t work.

    #489085

    Hi!

    It looks like you copied the code into both the parent and child theme functions.php file which is going to give you an error. Delete the code from the parent theme functions.php file.

    If your still having problems then completely delete Enfold from your WordPress theme directory before downloading + uploading a fresh copy from themeforest and we’ll do the edit for you.

    Cheers!
    Elliott

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.