Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #1033561

    Hi, I’m having an issue with font weight not being applied correctly to my headings (H1, H2). I went into Enfold > Advanced Styling and set H1 and H2 tags to have font-weight of 900. (I want my headings to be very bold and prominent). Font family is set to “Raleway,” which I know supports multiple weights. However, as you can see here, font weight looks nothing like 900. If I use a visual inspector in Chrome and inspect H1 and H2, it tells me that font-weight: 900; but visually the headings don’t look that way. I’m not sure what’s overwriting this property and where to look for it.

    #1033825

    Hey erin-s,

    I checked all the font-weights in the browser and they seem to be working. It doesn’t look all that different compared to here either: https://fonts.google.com/specimen/Raleway

    Best regards,
    Rikard

    #1035032

    Hi Rikard, please see attached. If you compare Ralewey in 900 font weight on Google Fonts (top) and on my site (bottom), the fonts looks very different. I set the headings on my site to 900 font-weight, but they looks “semi-bold” at best. I need them to look like “black.” I’m not sure how to address this issue on my site.

    #1035855

    Hi,

    Are you loading the Raleway 900 also because I do not see it at the source to be loading properly.

    Best regards,
    Basilis

    #1036060
    This reply has been marked as private.
    #1036985

    Hi Rob,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Best regards,
    Victoria

    #1037145

    Hi Victoria, thank you for your help! Please see login credentials in the box below.

    #1037962

    Hi Victoria,

    I have added the admin login details in the box below. If you need anything else, please let me know.

    Best,

    Rob

    #1039909

    Hi erin-s,

    I’m very sorry for the late reply, what happens if you import the 900 weight in your CSS in Quick CSS for instance?

    @import url('https://fonts.googleapis.com/css?family=Raleway:900');

    You could also try to download it from Google Fonts, then upload to the theme under Enfold->Import/Export.

    Best regards,
    Rikard

    #1039910

    Hi Rob,

    Sorry again for the late replies, could you try what I recommended to erin-s to see if you have any luck with it as well?

    @import url('https://fonts.googleapis.com/css?family=Montserrat:900');

    Best regards,
    Rikard

    #1126701

    Hey guys, did you have any luck with these, because I appear to be having the same issue?
    I have tried to add the quick CSS.
    Many thanks.

    #1126920

    Hi wmeida,

    Could you please give us a link to your website, we need more context to be able to help you.

    Best regards,
    Victoria

    #1127384

    Hi all,
    I’ve been seeing the same thing. All was fine as of this spring but after one or two theme updates, we lost all the weight styles. We’ve installed the montserrat font through the theme options as well as applied to the header styles within the advanced styling options but nothing has changed. What’s odd is that on some pages the font weight comes through but on 90% of the areas where font weight within special headers is applied, it’s rendering as “normal” even though when using the browser inspector tool (firefox, chrome and safari, it shows that the font weight is right. Just visually it’s normal. Very odd.
    Thanks
    -E

    #1127396

    Ok, figured it out. Something must have changed with either how google manages their web fonts or how the Enfold theme does. Either way, I downloaded the font zip files from Google Fonts, uploaded them to through the import/export options within Enfold, hit save, and all my fonts are rendering with the correct font weight throughout the site. May want to inform users that whatever changes google and or Enfold made, some may need to reinstall the web font kits via Enfold’s font import settings.

    #1127555

    Hi Eric,

    Great, I’m glad that you got things working and thanks for sharing the solution, it’s much appreciated :-)

    Best regards,
    Rikard

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.