Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
  • #1033561

    Hi, I’m having an issue with font weight not being applied correctly to my headings (H1, H2). I went into Enfold > Advanced Styling and set H1 and H2 tags to have font-weight of 900. (I want my headings to be very bold and prominent). Font family is set to “Raleway,” which I know supports multiple weights. However, as you can see here, font weight looks nothing like 900. If I use a visual inspector in Chrome and inspect H1 and H2, it tells me that font-weight: 900; but visually the headings don’t look that way. I’m not sure what’s overwriting this property and where to look for it.


    Hey erin-s,

    I checked all the font-weights in the browser and they seem to be working. It doesn’t look all that different compared to here either:

    Best regards,


    Hi Rikard, please see attached. If you compare Ralewey in 900 font weight on Google Fonts (top) and on my site (bottom), the fonts looks very different. I set the headings on my site to 900 font-weight, but they looks “semi-bold” at best. I need them to look like “black.” I’m not sure how to address this issue on my site.



    Are you loading the Raleway 900 also because I do not see it at the source to be loading properly.

    Best regards,

    This reply has been marked as private.

    Hi Rob,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Best regards,


    Hi Victoria, thank you for your help! Please see login credentials in the box below.


    Hi Victoria,

    I have added the admin login details in the box below. If you need anything else, please let me know.




    Hi erin-s,

    I’m very sorry for the late reply, what happens if you import the 900 weight in your CSS in Quick CSS for instance?

    @import url('');

    You could also try to download it from Google Fonts, then upload to the theme under Enfold->Import/Export.

    Best regards,


    Hi Rob,

    Sorry again for the late replies, could you try what I recommended to erin-s to see if you have any luck with it as well?

    @import url('');

    Best regards,


    Hey guys, did you have any luck with these, because I appear to be having the same issue?
    I have tried to add the quick CSS.
    Many thanks.


    Hi wmeida,

    Could you please give us a link to your website, we need more context to be able to help you.

    Best regards,


    Hi all,
    I’ve been seeing the same thing. All was fine as of this spring but after one or two theme updates, we lost all the weight styles. We’ve installed the montserrat font through the theme options as well as applied to the header styles within the advanced styling options but nothing has changed. What’s odd is that on some pages the font weight comes through but on 90% of the areas where font weight within special headers is applied, it’s rendering as “normal” even though when using the browser inspector tool (firefox, chrome and safari, it shows that the font weight is right. Just visually it’s normal. Very odd.


    Ok, figured it out. Something must have changed with either how google manages their web fonts or how the Enfold theme does. Either way, I downloaded the font zip files from Google Fonts, uploaded them to through the import/export options within Enfold, hit save, and all my fonts are rendering with the correct font weight throughout the site. May want to inform users that whatever changes google and or Enfold made, some may need to reinstall the web font kits via Enfold’s font import settings.


    Hi Eric,

    Great, I’m glad that you got things working and thanks for sharing the solution, it’s much appreciated :-)

    Best regards,


    I’ve noticed the same issue. I also had an issue with the font showing up as Italics when I did the font import. I think I have it fixed now, but there are clearly some glitches with Google Fonts and Enfold right now.


    Hi vaology,

    Thanks for the feedback.

    Best regards,


    Hi! This are not glitches. By default Enfolds loads only a few weights (e.g. 400 and 600). When you want to add additional weights, see this post:



    Thanks for sharing @Eneas, it’s much appreciated :-)

    Best regards,


    I am having a similar issue with Work Sans. I want to use the 200 and the 300 but I seem to only be getting the 100 and the 400. I uploaded the Google font for the 200 and the 300. I also tried the 2 additions to the CSS detailed in this thread:

    @import url(‘’);

    add_filter( ‘avf_google_heading_font’, ‘avia_add_content_font’);
    add_filter( ‘avf_google_content_font’, ‘avia_add_content_font’);
    function avia_add_content_font($fonts)
    $fonts[‘Work Sans’] = ‘Open Sans:200,300, 400’;
    $fonts[‘Work Sans’] = ‘Open Sans:200,300, 400’;
    return $fonts;

    Right now I have selected Work Sans as the heading and body font in General Styling and used Advanced Styling to select the 300 version but I am getting the 100.

    Thanks in advance for the guidance.


    Hi tiffanytnttobol,

    Please open a new thread and include WordPress admin login details in private, so that we can have a closer look at your site.

    Best regards,

Viewing 21 posts - 1 through 21 (of 21 total)
  • You must be logged in to reply to this topic.