Tagged: ,

Viewing 28 posts - 1 through 28 (of 28 total)
  • Author
    Posts
  • #816864

    I use google font’s “Heebo” font.
    I chose it in the theme options.
    Thing is every time I update the theme, the font resets to “default” or “Arial”.
    Hope you’ll check it so it will stop in the next update.

    #817059

    Hey barak97,

    Please send us a temporary admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #817325

    See private content.

    #817594

    Hi,

    Thanks for that, I changed the font to Heebo and saved and it looks to be sticking. Is this only happening when updating the theme or does it happen when you change something in the theme options as well?

    Best regards,
    Rikard

    #817696

    If I notice right, only when updating the theme.

    #817761

    Hi,

    Ok, thanks for the feedback. I think it will be hard to debug the issue if it only happens on updates unfortunately. Are you ok with checking that setting each time you update? We haven’t had anyone else report such a problem so I think it might be something local to your installation.

    Best regards,
    Rikard

    #817816

    I guess I won’t have another option… Weird that it is only in my site, but Ok. Thank you!

    #818068

    Hi,

    Sorry but it would be very difficult for us to find the problem unfortunately, if we even could. We’ll keep the thread open in case it should happen on the next update as well, or maybe you will have some more clues as to why it’s happening.

    Best regards,
    Rikard

    #824677

    I think I found it!
    The font settings resets everytime I clean cache with “WP ROCKET” plugin.

    #824981

    Hi,

    Ok, not sure why that would be but glad you found the problem anyway :-)

    Best regards,
    Rikard

    #860563

    Now I come across a worse problem… The font settings seems to not be saved at all.
    After choosing the font and hitting “save all changes”, I click on the theme settings on the sidebar, go to “General styling” page and it’s like I didn’t change anything at all – goes back to “Default” and “Arial”.

    Is there a way to disable this option? Override it?
    Even when using a google font plugin it doesn’t override the theme settings.
    Any help?

    #861775

    Hi,

    The login credentials are not working. Please check it carefully. Is it working properly if the cache plugin is disabled?

    Best regards,
    Ismael

    #866670

    Updated login credentials are in the private content.

    I tried to check it when cache is disabled, and the problem still occurs.
    But when I chose another fonts from the list in the “fonts” segment under “General Styling” – the setting was saved correctly. So it seems like there is a specific problem with the Heebo font.
    It was added to the list via a code that I inserted to the function.php file after I read instructions in this forum. This is the code:

    add_filter( 'avf_google_heading_font', 'avia_add_heading_font');
    function avia_add_heading_font($fonts)
    {
    $fonts['Heebo'] = 'Heebo:400,500,700&subset=hebrew';
    return $fonts;
    }
    
    add_filter( 'avf_google_content_font', 'avia_add_content_font');
    function avia_add_content_font($fonts)
    {
    
    $fonts['Heebo'] = 'Heebo:400,500,700&subset=hebrew';
    return $fonts;
    }
    
    • This reply was modified 6 years, 9 months ago by barak97.
    #866963

    Hi,

    The “heebo” font is already included in the heading font selection so you don’t need to add the “avf_google_heading_font” filter. Please replace the filter with the following code.

    add_filter( 'avf_google_content_font', 'avia_add_content_font');
    function avia_add_content_font($fonts)
    {
    
    $fonts['Google fonts']['Heebo'] = 'Heebo:400,500,700&subset=hebrew';
    return $fonts;
    }

    Re-select the font in the “Defines the Font for your body text” settings under “Google fonts”.

    Best regards,
    Ismael

    #867008

    It did work for the Heading font – the setting stayed after refreshing the page.
    Unfortunately, it didn’t work for the Body font which resets itself to Arial :(

    #867227

    Hi barak97,

    Can you give the user above the admin rights, please?

    Best regards,
    Victoria

    #867228

    Yes, it has now.

    #867337

    Hi barak97,

    Thanks. You can set the font for the h1-h6 headings. I set it and it shows on the website.

    Best regards,
    Victoria

    #867361

    Yes, but I want the Body font to be in Heebo too… :)

    #867951

    Hi,

    Looks like the frontend body font is already set to “Heebo” even if it’s not set in the backend. If not, please add this filter which enables you to use a specific font without using the theme options.

    add_action('init', 'ava_google_font');
    function ava_google_font() {
      global $avia;
      $avia->options['avia']['google_webfont'] = 'Heebo:100,400,700';
      return $avia;
    }
    

    Best regards,
    Ismael

    #868245

    Great! It worked. Thank you

    #868259

    Hi,

    Glad that Ismael helped you. Let us know if you need more assistance or if we can close the thread :)

    Best regards,
    Nikko

    #869831

    @Ismael , After testing on a few devices, it seems like the code doesn’t bypass the font settings in the theme settings…
    Even though it is in the functions.php file, I see Arial as the body font… :(

    #869878

    Hi barak97,

    When is it happening? Specific devices or browsers?

    Best regards,
    Victoria

    #869885

    In chrome for desktop, chrome mobile on android, safari on iphone 5…
    Seems like the filter doesn’t really work.

    #869961

    Hi,

    Did you try the following hook?

    add_action('init', 'ava_google_font');
    function ava_google_font() {
      global $avia;
      $avia->options['avia']['google_webfont'] = 'Heebo:300,400,700&subset=hebrew';
      return $avia;
    }
    

    Best regards,
    Ismael

    #869972

    @Ismael
    Yeah, it’s inside the functions.php file, but seems like it doesn’t have any effect…

    #870363

    Hi,

    The “Heebo” font is loaded twice, that’s why it’s not working. We set the “body” font to “Arial” and the “heading” font to “Heebo”. Please specify the body font manually in the Quick CSS field.

    body {
        font-family: 'Heebo', 'HelveticaNeue', 'Helvetica Neue', Helvetica, Arial, sans-serif;
    }

    Best regards,
    Ismael

Viewing 28 posts - 1 through 28 (of 28 total)
  • You must be logged in to reply to this topic.